Re: Too many open files to the master oninit process
Posted in 2004
Hello Mr. Weitkamp :-) what you're describing probably is known as Informix Bug: 157885 CDR DEFINE SERVER FAILS WITH 'NO GROUP ENTRY FOR <GRP>' IF TOO MANY FDS OPEN and Bug: 157955 DUE TO STDIO LIMITATIONS - FOPEN MAY FAIL IF FILE DESCRIPTORS BELOW 256 ARE NOT AVAILABLE The underlying problem - on some platforms - is, that the file descriptor field in the FILE struct returned by a fopen() call is a single byte field providing space for file descriptors 0 - 255 only. In case there are no more free file descriptor below 256, fopen() will fail. I.e. we're clearly running into an OS limitation. The fix, available from 7.31.xD6 and 9.30.xC5 onwards, takes care of this problem by ensuring that file descriptors for chunks and sockets always are above 256, thus reserving the lower numbers for the few occasions where IDS uses f...() stdio calls. If you incur this problem (i.e. don't have the fix) there probably is no way to avoid a server restart :-( Best, Andreas Legner