This happens when you create the tables in a different order in the target
server then they were created in the server on which you ran the dbschema. Edit
the schema for the table and remove the CONSTRAINT NOT NULL constraints and
replace them with old style NOT NULL clauses. Same for any other auto-named
constraints you find, either give them explicit names yourself (other than the
generated name of course) or 'CONSTRAINT constraint_name' clause altogether so
that a new name is generated. You can avoid this by using my dbschema
replacement utility, myschema, in the future. This problem is one of the
reasons I maintain the beasty. Myschema is contained in the package utils2_ak
available for download from the IIUG Software Repository.
Art S. Kagel
----- Original Message -----
From: Jay Zwagerman <jay2@iafalls.com>
At: 4/ 9 15:40
> Hello
>
> I recently posted a question on how to copy a table format, and I was told to
> use the dbschema. This has worked fine, but I for one table I am getting an
> error message. Here is what I have. Can someone help me out?
>
> 5% dbschema -d prt -t tcc_shop awj_shop.sql>
> DBSCHEMA Schema Utility INFORMIX-SQL Version 7.23.UC13
> Copyright (C) Informix Software, Inc., 1984-1997
> Software Serial Number AAC#J788759
> 100 - ISAM error: duplicate value for a record with unique key.
>
> 6% finderr 100
> -100 ISAM error: duplicate value for a record with unique
> key.
>
> A row that was to be inserted or updated has a key value that already
> exists in its index. For C-ISAM programs, a duplicate value was
> presented in the last call to iswrite, isrewrite, isrewcurr, or
> isaddindex. Review the program logic and the input data. For SQL
> products, a duplicate key value was used in the last INSERT or UPDATE.