Onbar can't restore IDS
Posted in 2003
Topics: Backup & Restore, Storage & Space Management
Hi All.
I try to restore Informix dynamic server 7.31 uc5 on SCO Open server
and it failed with errors.
2003-12-16 12:28:52 5971 5970 /u/informix/bin/onbar_d -r -w
2003-12-16 12:31:32 5971 5970 Successfully connected to Storage Manager.
2003-12-16 12:31:32 5971 5970 XBSA Error (BSAGetObject): Backup object does
not exist in Storage Manager.
But I don't see any problem with ism.
#ism_show -volumes
volume pool flags written (%) expires
dhi031215 ISMDiskData 4291 MB 100% 12/14/05
#ism_show -devices
file disk dhi031215 mounted on /u_ism/backup_ids, write protected
#nsrinfo privdhi
scanning client `privdhi' for all savetimes from the backup namespace
/u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55 2003
/, date=1071561475 Tue Dec 16 09:57:55 2003
/u//, date=1071561475 Tue Dec 16 09:57:55 2003
/u/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/ism/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/ism/index/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/ism/index/privdhi/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55 2003
10 objects found
#nsrim -v
privdhi:/u/informix/ism/index/privdhi, retention policy: Year, 1 browsable
cycle
(s)
1780 12/16/03 f 8 files 5 KB browse
8 browsable files of 8 total, 5 KB recoverable of 5 KB total
privdhi:INFORMIX:/privdhi/rootdbs/0, retention policy: Year, browse policy:
Mont
h
1775 12/15/03 f 1 files 12 MB browse
1776 12/15/03 f 1 files 63 KB browse
1777 12/15/03 f 3 files 4258 MB browse
5 browsable files of 5 total, 4270 MB recoverable of 4270 MB total
dhi031215: 4291 MB used, 6 save sets, appendable, 6 browsable save sets
Compressing media db... done.
There are following evironment
INFORMIXDIR=/u/informix
INFORMIXSERVER=prime12ISMDIR=/u/informix/ism
ISM_CLIENT=privdhi
ISM_COMPRESSION=TRUE
ISM_DATA_VOLUME_POOL=ISMDiskData
ISM_LOG_VOLUME_POOL=ISMDiskData
ISM_SERVER=prime12
NSR_CLIENT=privdhi
NSR_DEBUG_LEVEL=7
NSR_SERVER=prime12
Please explain me why onbar can't find object to restore.
And there not any informations in /u/informix/ism/applogs/xbsa.messages.
why ?
There are ISM_DEBUG_LEVEL=7.
What object it is searching?
Thanks for any suggestions.
Best regards, Konstatnin.
p.s.Help Me, My mind is boilling 8-)
Hi.
I have found on the IBM site
http://www-306.ibm.com/software/data/informix/pubs/library/notes/machnote/C17012
6.html
2. Bug Number: 152157
Short Description:
ONBAR/ISM RESTORE MAY FAIL WITH XBSA ERROR: (BSAGETOBJECT) BACKUP OBJECT
DOES NOT EXIST IN STORAGE MANAGER ON SOLARIS 64-BIT
But I didn't find more information about this bug.
What about this behavior in older version of informix & onbar?
Is there any way to pass this ?
Best regards,
Konstantin.
----- Original Message -----
From: "Konstantin ...." <cvk@pbcards.dp.ua>
To: <ids@iiug.org>
Sent: Tuesday, December 16, 2003 4:53 PM
Subject: Onbar can't restore IDS [2360]
> Hi All.
>
>
> I try to restore Informix dynamic server 7.31 uc5 on SCO Open server
> and it failed with errors.
>
> 2003-12-16 12:28:52 5971 5970 /u/informix/bin/onbar_d -r -w
> 2003-12-16 12:31:32 5971 5970 Successfully connected to Storage Manager.
> 2003-12-16 12:31:32 5971 5970 XBSA Error (BSAGetObject): Backup object
does
> not exist in Storage Manager.
>
> But I don't see any problem with ism.
>
> #ism_show -volumes
> volume pool flags written (%) expires
> dhi031215 ISMDiskData 4291 MB 100% 12/14/05
>
> #ism_show -devices
> file disk dhi031215 mounted on /u_ism/backup_ids, write protected
>
>
> #nsrinfo privdhi
>
> scanning client `privdhi' for all savetimes from the backup namespace
> /u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55
2003
> /u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55
2003
> /, date=1071561475 Tue Dec 16 09:57:55 2003
> /u//, date=1071561475 Tue Dec 16 09:57:55 2003
> /u/, date=1071561475 Tue Dec 16 09:57:55 2003
> /u/informix/, date=1071561475 Tue Dec 16 09:57:55 2003
> /u/informix/ism/, date=1071561475 Tue Dec 16 09:57:55 2003
> /u/informix/ism/index/, date=1071561475 Tue Dec 16 09:57:55 2003
> /u/informix/ism/index/privdhi/, date=1071561475 Tue Dec 16 09:57:55 2003
> /u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55
2003
> 10 objects found
>
> #nsrim -v
>
> privdhi:/u/informix/ism/index/privdhi, retention policy: Year, 1 browsable
> cycle
> (s)
> 1780 12/16/03 f 8 files 5 KB browse
> 8 browsable files of 8 total, 5 KB recoverable of 5 KB total
>
> privdhi:INFORMIX:/privdhi/rootdbs/0, retention policy: Year, browse
policy:
> Mont
> h
> 1775 12/15/03 f 1 files 12 MB browse
> 1776 12/15/03 f 1 files 63 KB browse
> 1777 12/15/03 f 3 files 4258 MB browse
> 5 browsable files of 5 total, 4270 MB recoverable of 4270 MB total
>
>
> dhi031215: 4291 MB used, 6 save sets, appendable, 6 browsable save
sets
>
> Compressing media db... done.
>
>
> There are following evironment
>
> INFORMIXDIR=/u/informix
> INFORMIXSERVER=prime12> ISMDIR=/u/informix/ism
> ISM_CLIENT=privdhi
> ISM_COMPRESSION=TRUE
> ISM_DATA_VOLUME_POOL=ISMDiskData
> ISM_LOG_VOLUME_POOL=ISMDiskData
> ISM_SERVER=prime12
> NSR_CLIENT=privdhi
> NSR_DEBUG_LEVEL=7
> NSR_SERVER=prime12
>
>
> Please explain me why onbar can't find object to restore.
> And there not any informations in /u/informix/ism/applogs/xbsa.messages.
> why ?
> There are ISM_DEBUG_LEVEL=7.
> What object it is searching?
>
>
> Thanks for any suggestions.
>
> Best regards, Konstatnin.
>
> p.s.Help Me, My mind is boilling 8-)
>
>
>
Your
ixbar file does not match the savesets. You get this error when they
don't match. Then follow every minor instruction, you should be ok.
Vivek
-----Original Message-----
From: forum.subscriber@iiug.org [mailto:forum.subscriber@iiug.org] On Behalf
Of Konstantin ....
Sent: Tuesday, December 16, 2003 7:53 AM
To: ids@iiug.org
Subject: Onbar can't restore IDS [2360]
Hi All.
I try to restore Informix dynamic server 7.31 uc5 on SCO Open server and it
failed with errors.
2003-12-16 12:28:52 5971 5970 /u/informix/bin/onbar_d -r -w 2003-12-16
12:31:32 5971 5970 Successfully connected to Storage Manager. 2003-12-16
12:31:32 5971 5970 XBSA Error (BSAGetObject): Backup object does not exist
in Storage Manager.
But I don't see any problem with ism.
#ism_show -volumes
volume pool flags written (%) expires
dhi031215 ISMDiskData 4291 MB 100% 12/14/05
#ism_show -devices
file disk dhi031215 mounted on /u_ism/backup_ids, write protected
#nsrinfo privdhi
scanning client `privdhi' for all savetimes from the backup namespace
/u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55 2003
/u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16 09:57:55 2003
/, date=1071561475 Tue Dec 16 09:57:55 2003 /u//, date=1071561475 Tue Dec 16
09:57:55 2003 /u/, date=1071561475 Tue Dec 16 09:57:55 2003 /u/informix/,
date=1071561475 Tue Dec 16 09:57:55 2003 /u/informix/ism/, date=1071561475
Tue Dec 16 09:57:55 2003 /u/informix/ism/index/, date=1071561475 Tue Dec 16
09:57:55 2003 /u/informix/ism/index/privdhi/, date=1071561475 Tue Dec 16
09:57:55 2003 /u/informix/ism/index/privdhi/db/, date=1071561475 Tue Dec 16
09:57:55 2003 10 objects found
#nsrim -v
privdhi:/u/informix/ism/index/privdhi, retention policy: Year, 1 browsable
cycle
(s)
1780 12/16/03 f 8 files 5 KB browse
8 browsable files of 8 total, 5 KB recoverable of 5 KB total
privdhi:INFORMIX:/privdhi/rootdbs/0, retention policy: Year, browse policy:
Mont h
1775 12/15/03 f 1 files 12 MB browse
1776 12/15/03 f 1 files 63 KB browse
1777 12/15/03 f 3 files 4258 MB browse
5 browsable files of 5 total, 4270 MB recoverable of 4270 MB total
dhi031215: 4291 MB used, 6 save sets, appendable, 6 browsable save sets
Compressing media db... done.
There are following evironment
INFORMIXDIR=/u/informix
INFORMIXSERVER=prime12ISMDIR=/u/informix/ism
ISM_CLIENT=privdhi
ISM_COMPRESSION=TRUE
ISM_DATA_VOLUME_POOL=ISMDiskData ISM_LOG_VOLUME_POOL=ISMDiskData
ISM_SERVER=prime12 NSR_CLIENT=privdhi NSR_DEBUG_LEVEL=7 NSR_SERVER=prime12
Please explain me why onbar can't find object to restore.
And there not any informations in /u/informix/ism/applogs/xbsa.messages.
why ?
There are ISM_DEBUG_LEVEL=7.
What object it is searching?
Thanks for any suggestions.
Best regards, Konstatnin.
p.s.Help Me, My mind is boilling 8-)
Related threads
- Re: Re: Crash course for an Oracle DBA
- Re: IDS 7.30 do not start - NT
- Re: IDS 10 erratic run times
- Client SDK