REgarding the Error in Logical Logs
Posted in 2004
Topics: Error Codes & Troubleshooting, Logging & Checkpoints
Hi,
We are running Informix 9.3 on Sun OS 5.8 . I cannot get my database
engine up because of following error :
12:36:39 Results: Log record (OLDRSAM:HDELETE) in log 95507, offset
0xdf352c was not rolled back
12:36:39 Action: Use 'onlog' to view the transaction and repair manually.
12:36:39 stack trace for pid 5330 written to
/export1/home/informix/log/af.42a0556
12:36:39 See Also: /export1/home/informix/log/af.42a0556, shmem.42a0556.0
12:37:05 Rollback error 172
12:37:06 Assert Failed: Rollback error 172
Can somebody tell me how to use the onlog to repair the log 99507 ?
Thanks,
Jiten
We've
seen this message in several cases and we love this kind of humor
;-)) (I don't know a customer who could solve this problem by using
onlog -n-l logid)
The database will not come up in this case because of errors in logical
recovery. The only way to solve this problem is to open a case and ask
INFORMIX to patch the logs .... or you look for your last backup and
restore this one without the last logical log.
Jiten Thakkar wrote:
>Hi,
>
>We are running Informix 9.3 on Sun OS 5.8 . I cannot get my database
>engine up because of following error :
>
>12:36:39 Results: Log record (OLDRSAM:HDELETE) in log 95507, offset
>0xdf352c was not rolled back
>12:36:39 Action: Use 'onlog' to view the transaction and repair manually.
>12:36:39 stack trace for pid 5330 written to
>/export1/home/informix/log/af.42a0556
>12:36:39 See Also: /export1/home/informix/log/af.42a0556, shmem.42a0556.0
>12:37:05 Rollback error 172
>12:37:06 Assert Failed: Rollback error 172
>
>Can somebody tell me how to use the onlog to repair the log 99507 ?
>
>Thanks,
>Jiten
>
>
--
Gerd Kaluzinski Tel. :+49-(0)7541-585-5000
Manager Consulting Fax :+49-(0)7541-585-5500
BYTEC GmbH mailto:support@bytec.de
Hermann-Metzger-Str.7 http://www.bytec.de
88045 Friedrichshafen
Jiten ,
The information is not sufficient to determine the root cause.
Also, I guess it will require a dialin of a support engineer to
investigate this
From what I see, it appears to me that happend after the IDS server
went down for some reason , i.e. it was crashed instead of brought down
clean . Is this correct?
If so , why did it crash in the first place ?
What IDS version do you use?
Do you use the so called FUZZY CHECKPOINTS ?
If so, I suggest to start IDS with the environment variable NOFUZZYCKPT set
to 1.
That will avoid fuzzy checkpoints.
I recall that there have been problems with fast recovery when fuzzy
checkpoints are used.
With kind regards
Tilman Model-Bosch
--
Tilman Model-Bosch
IBM Data Managment Solutions, Informix Advanced Support
c\\\\o SAP AG
TECHDEV 05
Neurrotstr.16
69190 Walldorf
Jiten Thakkar
<jthakkar@lsil.co To: Tilman Model-Bosch/Germany/IBM@IBMDE
m> cc:
Subject: Re: REgarding the Error in Logical Logs [2433]
01/13/2004 07:29
PM
Hi ,
Thanks for the reply.
Unfortunately we do not have any Informix support and hence I had to
restore the database from the backups.
If possible can you tell me why this happens and if there are any ways
to prevent this type of errors.
This is the second time in 4 months we have to restore the database
because of this error.
Regards,
Jiten
Tilman Model-Bosch wrote:
>Hello Jiten,
>
>This message about onlog is a bit of a euphemism.
>
>You may either call Informix Tech support and ask them to dial in and fix
>it or
>you may restore the instance.
>
>With kind regards
>Tilman
>
>--
>Tilman Model-Bosch
>IBM Data Managment Solutions, Informix Advanced Support
>c\\\\o SAP AG
>TECHDEV 05
>Neurrotstr.16
>69190 Walldorf
>
>
>
>
>
>
> "Jiten Thakkar "
> <jthakkar@lsil.co To: ids@iiug.org
> m> cc:
> Sent by: Subject: REgarding the
Error in Logical Logs [2433]
> forum.subscriber@
> iiug.org
>
>
> 01/12/2004 11:52
> PM
>
>
>
>
>
>Hi,
>
>We are running Informix 9.3 on Sun OS 5.8 . I cannot get my database
>engine up because of following error :
>
>12:36:39 Results: Log record (OLDRSAM:HDELETE) in log 95507, offset
>0xdf352c was not rolled back
>12:36:39 Action: Use 'onlog' to view the transaction and repair
manually.
>12:36:39 stack trace for pid 5330 written to
>/export1/home/informix/log/af.42a0556
>12:36:39 See Also: /export1/home/informix/log/af.42a0556,
shmem.42a0556.0
>12:37:05 Rollback error 172
>12:37:06 Assert Failed: Rollback error 172
>
>Can somebody tell me how to use the onlog to repair the log 99507 ?
>
>Thanks,
>Jiten
>
>
>
>
>
>
>