Informix IDS 9.4 failed to initialized shared memory
Posted in 2005
Topics: Installation, Setup & Upgrades, Storage & Space Management, Server Administration, Logging & Checkpoints, Networking & sqlhosts Configuration, Versions, Editions & End-of-Life
I just installed Informix IDS 9.4 on Mandrake 10.1 Kernel 2.6.x
I setup the onconfig file. the following are some of the parameters I
set:
# Root Dbspace Configuration
ROOTNAME rootdbs1 # Root dbspace nameROOTPATH /home/informix/dbspaces/rootdbs1
# Path for device containing root dbspace
SERVERNUM 1 # Unique id corresponding to a OnLineinstance
DBSERVERNAME olmids1 # Name of default database server
# Shared Memory Parameters
LOCKS 2000 # Maximum number of locks
BUFFERS 1000 # Maximum number of shared buffers
NUMAIOVPS # Number of IO vps
PHYSBUFF 32 # Physical log buffer size (Kbytes)
LOGBUFF 32 # Logical log buffer size (Kbytes)
CLEANERS 1 # Number of buffer cleaner processes
SHMBASE 0x10000000L # Shared memory base address 44000000L
SHMVIRTSIZE 8000 # initial virtual shared memory segmentsize
SHMADD 8192 # Size of new shared memory segments
(Kbytes)
SHMTOTAL 128000 # Total shared memory (Kbytes).
0=>unlimited
CKPTINTVL 300 # Check point interval (in sec)
LRUS 8 # Number of LRU queues
LRU_MAX_DIRTY 60.000000 # LRU percent dirty begin cleaning limit
LRU_MIN_DIRTY 50.000000 # LRU percent dirty end cleaning limit
TXTIMEOUT 0x12c # Transaction timeout (in sec)
STACKSIZE 32 # Stack size (Kbytes)
I used the onmonitor and tried to startup the instance but it failed with:
failed to initialized shared memory.
I checked the log file but there are no messages about the problem.
I did not change/add/modify the parameters in the kernel ( I am new in
Linux ;-))
And I think that is the problem.
Does somebody know what parameters I need to set?
what values will be good to use?
What file do I need to modify?
Permissions? etc.
Regards,
Gerardo.
My machine has only 768 in RAM.
Chivi wrote:
> I just installed Informix IDS 9.4 on Mandrake 10.1 Kernel 2.6.x
>
> I setup the onconfig file. the following are some of the parameters I
> set:
> # Root Dbspace Configuration
>
> ROOTNAME rootdbs1 # Root dbspace name> ROOTPATH /home/informix/dbspaces/rootdbs1
> # Path for device containing root dbspace
> SERVERNUM 1 # Unique id corresponding to a OnLine> instance
> DBSERVERNAME olmids1 # Name of default database server>
> # Shared Memory Parameters
>
> LOCKS 2000 # Maximum number of locks
> BUFFERS 1000 # Maximum number of shared buffers
> NUMAIOVPS # Number of IO vps
> PHYSBUFF 32 # Physical log buffer size (Kbytes)
> LOGBUFF 32 # Logical log buffer size (Kbytes)
> CLEANERS 1 # Number of buffer cleaner processes
> SHMBASE 0x10000000L # Shared memory base address 44000000L
> SHMVIRTSIZE 8000 # initial virtual shared memory segment> size
> SHMADD 8192 # Size of new shared memory segments
> (Kbytes)
> SHMTOTAL 128000 # Total shared memory (Kbytes).
> 0=>unlimited
> CKPTINTVL 300 # Check point interval (in sec)
> LRUS 8 # Number of LRU queues
> LRU_MAX_DIRTY 60.000000 # LRU percent dirty begin cleaning limit
> LRU_MIN_DIRTY 50.000000 # LRU percent dirty end cleaning limit
> TXTIMEOUT 0x12c # Transaction timeout (in sec)
> STACKSIZE 32 # Stack size (Kbytes)>
>
> I used the onmonitor and tried to startup the instance but it failed with:
> failed to initialized shared memory.
> I checked the log file but there are no messages about the problem.
>
>
> I did not change/add/modify the parameters in the kernel ( I am new in
> Linux ;-))
> And I think that is the problem.
> Does somebody know what parameters I need to set?
> what values will be good to use?
> What file do I need to modify?
> Permissions? etc.
>
> My machine has only 768 in RAM.
I hope that's MB and not KB?
1000 buffers at 2K per buffer is 2MB - not very much on most machines.
Your SHMBASE line documents two values - why did you change anyything?
You limit your SHM to 128 MB (give or take) - I think you'd do better to
use a bit more up front - 10,000 BUFFERS?
Offhand, I don't recall having to modify the kernel to get shared memory
to work - but reading the machine notes would be a good idea to make
sure you know what they say; they might also clarify the value for SHMBASE.
You don't have the memory randomization feature enabled, do you? The
one that's in RedHat...
--
Jonathan Leffler #include <disclaimer.h>
Email: jleffler@earthlink.net, jleffler@us.ibm.com
Guardian of DBD::Informix v2005.01 -- http://dbi.perl.org/