Issue on ER "realize template" command
Posted in 2009
Topics: High Availability & Replication, Server Administration, Platform-Specific Issues
Hello to everybody! I´m trying to realize a 11.50.FC4 ER on two linux 64 machines, already started the cdr servers, all running fine, as follows: SERVER ID STATE STATUS QUEUE CONNECTION CHANGED ----------------------------------------------------------------------- g_central 81 Active Local 0 g_primary 80 Active Connected 0 Jul 23 08:10:52 I created then the template, also without any problems: TEMPLATE DATABASE TABLES ============================================== temp_teste fronteiras@sefaz30 dba.ocorrencia_fiscal But now, when I´m trying to realize it, it doesn´t work, and no specific error is generated on the screen, as flw: cdr realize template temp_teste -t -S "g_primary" -e delete "central@g_central" It raises the following error: command failed -- *Error* <206> is not a known Enterprise Replication error (206) Is there anyway how to trace the error? Is it the normal sql error 206 ( The specified table <table-name> is not in the database) ???? The only particular issue here is that the database names, on the primary and central machines are different. Obs: when running cdr realize template temp_teste -v "central@g_central" all returns fine, whithout any error!!! Verification of central@g_central:'dba'.ocorrencia_fiscal started Verification of central@g_central:'dba'.ocorrencia_fiscal is successful Thanks a lot for your help, friends!!!! -- Alexandre Marini Tecnologia da Informação - DBA SEFAZ-MS / SGI-UIMP / Sistemas IBM-Informix
Before you use g_primary as sync server while realizing template on g_central, make sure template is realized on g_primary server using 'cdr realize template' command. 206 is probably ER error code $cdr finderr 206 206 Template is not realized at sync source Thanks & Regards, Nagaraju From: "Alexandre Marini" <amarini@fazenda.ms.gov.br> To: ids@iiug.org Date: 07/23/2009 12:43 PM Subject: Issue on ER "realize template" command [16489] Hello to everybody! I´m trying to realize a 11.50.FC4 ER on two linux 64 machines, already started the cdr servers, all running fine, as follows: SERVER ID STATE STATUS QUEUE CONNECTION CHANGED ----------------------------------------------------------------------- g_central 81 Active Local 0 g_primary 80 Active Connected 0 Jul 23 08:10:52 I created then the template, also without any problems: TEMPLATE DATABASE TABLES ============================================== temp_teste fronteiras@sefaz30 dba.ocorrencia_fiscal But now, when I´m trying to realize it, it doesn´t work, and no specific error is generated on the screen, as flw: cdr realize template temp_teste -t -S "g_primary" -e delete "central@g_central" It raises the following error: command failed -- *Error* <206> is not a known Enterprise Replication error (206) Is there anyway how to trace the error? Is it the normal sql error 206 ( The specified table <table-name> is not in the database) ???? The only particular issue here is that the database names, on the primary and central machines are different. Obs: when running cdr realize template temp_teste -v "central@g_central" all returns fine, whithout any error!!! Verification of central@g_central:'dba'.ocorrencia_fiscal started Verification of central@g_central:'dba'.ocorrencia_fiscal is successful Thanks a lot for your help, friends!!!! -- Alexandre Marini Tecnologia da Informação - DBA SEFAZ-MS / SGI-UIMP / Sistemas IBM-Informix ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Regards!!!! It worked just fine!!! Thanks a lot for your help. Alexandre Marini Tecnologia da Informação - DBA SEFAZ-MS / SGI-UIMP / Sistemas IBM-Informix Nagaraju Inturi escreveu: > Before you use g_primary as sync server while realizing template on > g_central, make sure template is realized on g_primary server using 'cdr > realize template' command. > > 206 is probably ER error code > > $cdr finderr 206 > 206 Template is not realized at sync source > > Thanks & Regards, > Nagaraju > > From: > "Alexandre Marini" <amarini@fazenda.ms.gov.br> > To: > ids@iiug.org > Date: > 07/23/2009 12:43 PM > Subject: > Issue on ER "realize template" command [16489] > > Hello to everybody! > I´m trying to realize a 11.50.FC4 ER on two linux 64 machines, > already started the cdr servers, all running fine, as follows: > > SERVER ID STATE STATUS QUEUE CONNECTION CHANGED > ----------------------------------------------------------------------- > g_central 81 Active Local 0 > g_primary 80 Active Connected 0 Jul 23 08:10:52 > > I created then the template, also without any problems: > TEMPLATE DATABASE TABLES > ============================================== > temp_teste fronteiras@sefaz30 dba.ocorrencia_fiscal > > But now, when I´m trying to realize it, it doesn´t work, and no specific > error is generated on the screen, as flw: > cdr realize template temp_teste -t -S "g_primary" -e delete > "central@g_central" > > It raises the following error: > command failed -- *Error* <206> is not a known Enterprise Replication > error (206) > > Is there anyway how to trace the error? > Is it the normal sql error 206 ( The specified table <table-name> is not > in the database) ???? > > The only particular issue here is that the database names, on the > primary and central machines are different. > Obs: when running > cdr realize template temp_teste -v "central@g_central" > > all returns fine, whithout any error!!! > > Verification of central@g_central:'dba'.ocorrencia_fiscal started > Verification of central@g_central:'dba'.ocorrencia_fiscal is successful > > Thanks a lot for your help, friends!!!! >