Informix ODBC driver Error: A qouted string exceeds 256 bytes
Posted in 1999
Topics: Error Codes & Troubleshooting, Connectivity: ODBC / JDBC / .NET
Im currently trying to develope a web based interface to an informix database. I am using Cold Fusion server v3.1 and the informix 32 v2.8 ODBC driver. The problem is that when i try to insert into or update a table with a large text string i get the following error: Error Occurred While Processing Request Error Diagnostic Information ODBC Error Code = S1000 (General error) [Informix][Odbc Informix Driver][Informix]A quoted string exceeds 256 bytes. Date/Time: 03/29/99 10:00:55 Browser: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT) Remote Address: 172.21.27.63 HTTP Referer: http://scmdevel/intranet/newtar.cfm Template: C:\\InetPub\\wwwroot\\scmdevel\\intranet\\taradd.cfm Can i solve this problem by getting a new driver version, or is there some other way around this? thank you for any help you can offer. -----------== Posted via Deja News, The Discussion Network ==---------- http://www.dejanews.com/ Search, Read, Discuss, or Start Your Own
Dan wrote: > > Im currently trying to develope a web based interface to an informix database. > I am using Cold Fusion server v3.1 and the informix 32 v2.8 ODBC driver. The > problem is that when i try to insert into or update a table with a large text > string i get the following error: > > Error Occurred While Processing Request > Error Diagnostic Information > ODBC Error Code = S1000 (General error) > > [Informix][Odbc Informix Driver][Informix]A quoted string exceeds 256 bytes. > > Date/Time: 03/29/99 10:00:55 > Browser: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT) > Remote Address: 172.21.27.63 > HTTP Referer: http://scmdevel/intranet/newtar.cfm > Template: C:\\InetPub\\wwwroot\\scmdevel\\intranet\\taradd.cfm > > Can i solve this problem by getting a new driver version, No; it is the database which complains. > or is there some other way around this? In ESQL/C, you use a place-holder (?) instead of a string literal and then use a host variable to provide the value (which can be up to about 32 kB, then). I'm not sure how to translate that into ODBC. It is also a common problem for people who use DBD::Informix. -- Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN #include <disclaimer.h>
Hi, I used the SQL editor which is shipped with IDS Personal Edition or is part of ROM, and I got the same message. After that I tried QueryMan from Teradata and everything worked fine. So, in my opinion, it is not the engine that's complaining. Regards, Henk Jonathan Leffler wrote: > Dan wrote: > > > > Im currently trying to develope a web based interface to an informix database. > > I am using Cold Fusion server v3.1 and the informix 32 v2.8 ODBC driver. The > > problem is that when i try to insert into or update a table with a large text > > string i get the following error: > > > > Error Occurred While Processing Request > > Error Diagnostic Information > > ODBC Error Code = S1000 (General error) > > > > [Informix][Odbc Informix Driver][Informix]A quoted string exceeds 256 bytes. > > > > Date/Time: 03/29/99 10:00:55 > > Browser: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT) > > Remote Address: 172.21.27.63 > > HTTP Referer: http://scmdevel/intranet/newtar.cfm > > Template: C:\\InetPub\\wwwroot\\scmdevel\\intranet\\taradd.cfm > > > > Can i solve this problem by getting a new driver version, > > No; it is the database which complains. > > > or is there some other way around this? > > In ESQL/C, you use a place-holder (?) instead of a string literal > and then use a host variable to provide the value (which can be up > to about 32 kB, then). > > I'm not sure how to translate that into ODBC. > > It is also a common problem for people who use DBD::Informix. > -- > Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) > Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN > #include <disclaimer.h>
Hi, I used the SQL editor which is shipped with IDS Personal Edition or is part of ROM, and I got the same message. After that I tried QueryMan from Teradata and everything worked fine. So, in my opinion, it is not the engine that's complaining. Regards, Henk Jonathan Leffler wrote: > Dan wrote: > > > > Im currently trying to develope a web based interface to an informix database. > > I am using Cold Fusion server v3.1 and the informix 32 v2.8 ODBC driver. The > > problem is that when i try to insert into or update a table with a large text > > string i get the following error: > > > > Error Occurred While Processing Request > > Error Diagnostic Information > > ODBC Error Code = S1000 (General error) > > > > [Informix][Odbc Informix Driver][Informix]A quoted string exceeds 256 bytes. > > > > Date/Time: 03/29/99 10:00:55 > > Browser: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT) > > Remote Address: 172.21.27.63 > > HTTP Referer: http://scmdevel/intranet/newtar.cfm > > Template: C:\\InetPub\\wwwroot\\scmdevel\\intranet\\taradd.cfm > > > > Can i solve this problem by getting a new driver version, > > No; it is the database which complains. > > > or is there some other way around this? > > In ESQL/C, you use a place-holder (?) instead of a string literal > and then use a host variable to provide the value (which can be up > to about 32 kB, then). > > I'm not sure how to translate that into ODBC. > > It is also a common problem for people who use DBD::Informix. > -- > Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) > Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN > #include <disclaimer.h>
Hi, I used the SQL editor which is shipped with IDS Personal Edition or is part of ROM, and I got the same message. After that I tried QueryMan from Teradata and everything worked fine. So, in my opinion, it is not the engine that's complaining. Regards, Henk Jonathan Leffler wrote: > Dan wrote: > > > > Im currently trying to develope a web based interface to an informix database. > > I am using Cold Fusion server v3.1 and the informix 32 v2.8 ODBC driver. The > > problem is that when i try to insert into or update a table with a large text > > string i get the following error: > > > > Error Occurred While Processing Request > > Error Diagnostic Information > > ODBC Error Code = S1000 (General error) > > > > [Informix][Odbc Informix Driver][Informix]A quoted string exceeds 256 bytes. > > > > Date/Time: 03/29/99 10:00:55 > > Browser: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT) > > Remote Address: 172.21.27.63 > > HTTP Referer: http://scmdevel/intranet/newtar.cfm > > Template: C:\\InetPub\\wwwroot\\scmdevel\\intranet\\taradd.cfm > > > > Can i solve this problem by getting a new driver version, > > No; it is the database which complains. > > > or is there some other way around this? > > In ESQL/C, you use a place-holder (?) instead of a string literal > and then use a host variable to provide the value (which can be up > to about 32 kB, then). > > I'm not sure how to translate that into ODBC. > > It is also a common problem for people who use DBD::Informix. > -- > Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) > Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN > #include <disclaimer.h>