Re: Error 271
Posted in 1996
In article <jlumbleyDzrJpo.I1F@netcom.com>, Joe Lumbley
<jlumbley@netcom.com> writes
>Ramajig (ramajig@aol.com) wrote:
>: I'm using V7.11 of Informix on AIX platform with about 4GB of DB size.
>: While accessing an indexed table, I sometime receive error 271. The error
>: manual specifies that the row may be locked. I do find that the key next
>: to what I access is in a lock state caused by another user. I thought
>: that this adjacent row locking was a problem in Informix V5.x and not in
>: the later version(Least I expect it to be in V7.x !) The lock level of the
>: table is set to row and isolation level is set to repeatable read.
>: Am I to do anything more to resolve the error?
>: Anticipating a possible solution.
>: Thank you
>
>You're probably getting locks on the index pages. Try running a :
>
> set lock mode to wait 30;>
>command and see if the contention goes away.
No (Sorry)! If the 'access' (select/insert/update/delete? - which one?)
is probably not using an index to access the table. Remember if you do
not use an index you will do a sequential scan. This means you will lock
the whole table row by row. Under repeatable read isolation level the
locks are held UNTIL THE END OF THE TRANSACTION.
--
David Williams