HPL - load into fragmented table (round robin)
Posted in 2011
Hi Informix Gurus,
I have a silly question about HPL. I probably do something wrong...
I got an error loading data into fragmented table.
(round robin - 3fragments in separate dbspaces / original table layout is the
same). I unloaded/loaded 3 nonfragmented tables with HPL using same config
successfully. Only the fragmented table failed to load. The error is lack of
space in target dbspace. The number of records in the original table is 80mil
but it tries to load these 80mil into every single fragment of target table. I
have tried different versions but even with both tables on v11.7 it behaves in
the same way... The table doesn't use WITH ROWIDS. Standard load or
insert/select works fine.
EXPRESS mode (delimited file)
load job specifics >
onpladm create object -F book_det_l.arr -S myserver_1_soc
onpladm create job book_det_job_l -d book_det_l.dev -D db -t booking_details
-S myserver_1_soc -fal
#onpladm run job book_det_job_l -fl
array specifics (I have got 6 devices)
BEGIN OBJECT DEVICEARRAY book_det_l.dev
BEGIN SEQUENCE
TYPE PIPE
FILE
TAPEBLOCKSIZE 0
TAPEDEVICESIZE 0
PIPECOMMAND "gunzip < /appl/data/book_det1.gz"
END SEQUENCE
...
PIPECOMMAND "gunzip < /appl/data/book_det2.gz...
etc...