connection issues on 12.10 32bit
Posted in 2013
Topics: Installation, Setup & Upgrades, Error Codes & Troubleshooting, Connectivity: ODBC / JDBC / .NET, Server Administration, Networking & sqlhosts Configuration, Platform-Specific Issues
This concerns IDS 12.10.TC1IE on Windows server 2008 R2.
I find that c# programs using IfxConnection fail to connect unless the
INFORMIXSQLHOSTS environment variable is set to the server name or deleted
entirely.
But that stops dbschema, dbaccess, etc from running.
The registry was setup correctly under wow6432node by the Informix install.
I have to set informixsqlhosts=C:\\\\informix\\\\etc\\\\sqlhosts.mystiq to get informix
utilities to run
and âset informixsqlhost=â to get c# programs to connect.
Wow! that is inconvenient.
This problem started with 12.1 .
Also ODBC got broken in 12.1. Connections are slow to happen, but they connect
eventually.
I donât know if this could relate to the .net problem, but the connection is
on an ODBC provider..
Tracing reveals this:
--------------------------------------------------------------------------------
error code -11073
Option type out of range.
This IBM Informix CLI error code is the same as SQLSTATE value S1092.
The following functions can return this error code: SQLFreeStmt(),
SQLGetConnectOption(), SQLGetStmtOption(), SQLSetConnectOption(), and
SQLSetStmtOption().
The value specified for the argument fOption is in the block of numbers
reserved for CLI connection and statement option but is not valid for the
version of ODBC that the driver supports.
For a list of accepted descriptor types, check the IBM Informix CLI
Programmer's Manual.
The fOption argument was not a valid option value. Set fOption to a valid
value.
the driver version is 4.10.00.15184
--------------------------------------------------------------------------------
Anyone have either experience and find solutions?
You mention wow6432node, but that key is only for 64-bit systems. Are you
saying that the server is a 64-bit OS, and you're trying to setup the 32-bit
drivers for use with a 32-bit program?
--Justin
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
BillHatVerizon
Sent: Friday, July 12, 2013 6:53 PM
To: ids@iiug.org
Subject: connection issues on 12.10 32bit [30835]
This concerns IDS 12.10.TC1IE on Windows server 2008 R2.
I find that c# programs using IfxConnection fail to connect unless the
INFORMIXSQLHOSTS environment variable is set to the server name or deleted
entirely.
But that stops dbschema, dbaccess, etc from running.
The registry was setup correctly under wow6432node by the Informix install.
I have to set informixsqlhosts=C:\\\\informix\\\\etc\\\\sqlhosts.mystiq to get informix
utilities to run
and "set informixsqlhost=" to get c# programs to connect.
Wow! that is inconvenient.
This problem started with 12.1 .
Also ODBC got broken in 12.1. Connections are slow to happen, but they connect
eventually.
I don't know if this could relate to the .net problem, but the connection is
on an ODBC provider..
Tracing reveals this:
--------------------------------------------------------------------------------
error code -11073
Option type out of range.
This IBM Informix CLI error code is the same as SQLSTATE value S1092.
The following functions can return this error code: SQLFreeStmt(),
SQLGetConnectOption(), SQLGetStmtOption(), SQLSetConnectOption(), and
SQLSetStmtOption().
The value specified for the argument fOption is in the block of numbers
reserved for CLI connection and statement option but is not valid for the
version of ODBC that the driver supports.
For a list of accepted descriptor types, check the IBM Informix CLI
Programmer's Manual.
The fOption argument was not a valid option value. Set fOption to a valid
value.
the driver version is 4.10.00.15184
--------------------------------------------------------------------------------
Anyone have either experience and find solutions?
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
it is 64bit windows and 32 bit informix and 32bit odbc driver.
Been doin it for years.
-----Original Message-----
From: Justin Killen
Sent: Wednesday, July 17, 2013 12:41 PM
To: ids@iiug.org
Subject: RE: connection issues on 12.10 32bit [30875]
You mention wow6432node, but that key is only for 64-bit systems. Are you
saying that the server is a 64-bit OS, and you're trying to setup the 32-bit
drivers for use with a 32-bit program?
--Justin
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of
BillHatVerizon
Sent: Friday, July 12, 2013 6:53 PM
To: ids@iiug.org
Subject: connection issues on 12.10 32bit [30835]
This concerns IDS 12.10.TC1IE on Windows server 2008 R2.
I find that c# programs using IfxConnection fail to connect unless the
INFORMIXSQLHOSTS environment variable is set to the server name or deleted
entirely.
But that stops dbschema, dbaccess, etc from running.
The registry was setup correctly under wow6432node by the Informix install.
I have to set informixsqlhosts=C:\\\\informix\\\\etc\\\\sqlhosts.mystiq to get
informix
utilities to run
and "set informixsqlhost=" to get c# programs to connect.
Wow! that is inconvenient.
This problem started with 12.1 .
Also ODBC got broken in 12.1. Connections are slow to happen, but they
connect
eventually.
I don't know if this could relate to the .net problem, but the connection is
on an ODBC provider..
Tracing reveals this:
--------------------------------------------------------------------------------
error code -11073
Option type out of range.
This IBM Informix CLI error code is the same as SQLSTATE value S1092.
The following functions can return this error code: SQLFreeStmt(),
SQLGetConnectOption(), SQLGetStmtOption(), SQLSetConnectOption(), and
SQLSetStmtOption().
The value specified for the argument fOption is in the block of numbers
reserved for CLI connection and statement option but is not valid for the
version of ODBC that the driver supports.
For a list of accepted descriptor types, check the IBM Informix CLI
Programmer's Manual.
The fOption argument was not a valid option value. Set fOption to a valid
value.
the driver version is 4.10.00.15184
--------------------------------------------------------------------------------
Anyone have either experience and find solutions?
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.