Message error code 25588
Posted in 2014
Chet installed the wrong (older, 7.32.UC1) 4GL Interactive Debugger from Passport Advantage over an INFORMIXDIR shared with IDS 11.50.UC8 and tools 7.50.UC5, which overwrote shared libraries/message files so instances wouldn't start ("Cannot find message file... check INFORMIXDIR and DBLANG"). Art Kagel explained the library version clash and advised reinstalling ISQL and 4GL, then the engine (no uninstall needed), and if conflicts persist, installing 4GL/ISQL in a separate INFORMIXDIR with its own PATH/LD_LIBRARY_PATH and INFORMIXSQLHOSTS. Chet then hit a glibc 2.5 requirement on RHEL 4 when trying the 7.50 debugger; that last issue is left unresolved in the thread.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Backup & Restore, Installation, Setup & Upgrades, Error Codes & Troubleshooting
Running RHE AS Release 4, IDS 11.50 UC8. Just purchased and installed the Interactriv Debugger (probably a mistake) from IBM Passport Advantage Online. Installed fine from .tar file. No errors. Tried to start "all" instances with onmonitor. Received same error message "Cannot find message file. Check INFORMIXDIR and DBLANG. WARNING: server initialization failed, or possibly timed out (if -w was used). Check the message log, online.log, for errors." INFORMIXDIR is intact. DBLANG was never defined. Any way to back out the Interactive Debugger install? There were no error messages from the Interactive Debugger install at all. Since each instance is offline, Can I do a restore of each instance? I did a level 0 backup of each instance prior to the Debugger install. Thanks in advance for your help. Chet
This is the 4GL Interactive debugger? What version of it and what version of the engine do you have. Art Art S. Kagel, Principal Consultant ASK Database Management Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Wed, Jul 9, 2014 at 5:57 PM, CHESLEY BRION <cjb16@cornell.edu> wrote: > Running RHE AS Release 4, IDS 11.50 UC8. > > Just purchased and installed the Interactriv Debugger (probably a mistake) > from IBM Passport Advantage Online. Installed fine from .tar file. No > errors. > Tried to start "all" instances with onmonitor. Received same error message > "Cannot find message file. Check INFORMIXDIR and DBLANG. WARNING: server > initialization failed, or possibly timed out (if -w was used). Check the > message log, online.log, for errors." > > INFORMIXDIR is intact. DBLANG was never defined. > > Any way to back out the Interactive Debugger install? There were no error > messages from the Interactive Debugger install at all. Since each instance > is > offline, Can I do a restore of each instance? I did a level 0 backup of > each > instance prior to the Debugger install. > > Thanks in advance for your help. Chet > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001a11c36d9283f55904fdc9e304
Art: Yes..I have 1 programmer that uses 4gl Interactive Debugger (FGLDB)! We do have nearly 300,00 lines of code in 4gl. I think this is where the problem is. Totally my fault for not checking the version before I installed FGLDB from Passport Advantage. I simply selected the first Linux Version instead of the 7.50 UC5 version. Engine: 11.50 UC8 C4GL: 7.50 UC5 ISQL: 7.50 UC5 FGLDB: 7.32 UC1 I am thinking that the FGLDB install wiped something that IDS needs. Can I reinstall all products except FGLDB to get the directories back to where they were? Thx for assistance. Chet
WOW, I'm surprised it was working before. Yes, reinstall the ISQL and 4GL then the engine. If it was working before it should work now. What happened? First, you downloaded and installed an earlier version of the FGLDB (7.32) which has very old libraries. Second, the 4GL and ISQL that you have, v7.50.UC5 was last compiled with the v3.50.UC5 CSDK code and IBM reorganized the SQL libraries in .xC6 or so so even those libraries are incompatible with the ones delivered with your engine which is 11.50.UC5! Many sites have had to install 4GL and ISQL in directories separate from the engine to avoid breaking either the engine or 4GL/ISQL (whichever was installed first). If the reinstall gets the engine back online but the 4GL and ISQL stop working then install them into a separate directory and for 4GL/ISQL applications set INFORMIXDIR, PATH, and LD_LIBRARY_PATH pointing to that new location instead of the engine's INFORMIXDIR and either link your sqlhosts file from its actual location into the 4Gl installation's etc subdir or set INFORMIXSQLHOSTS to the actual past of the sqlhosts file. Finally, I would see if you can download the 7.50 release of FGLDB instead of the 7.32 release as there were several bug fixes and behavioral changes between 7.32 and 7.50. Last item, when you upgrade beyond 11.50 to 11.70 or 12.10 you should upgrade your tools (4GL, FGLDB, & ISQL) to the 7.51 release which was finally recompiled with a newer CSDK (4.10) which has libraries compatible with the later engines (not sure if it will be compatible with 11.50 though - ask IBM if you want to try it before upgrading). Art Art S. Kagel, Principal Consultant ASK Database Management Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jul 10, 2014 at 7:49 AM, CHESLEY BRION <cjb16@cornell.edu> wrote: > Art: > > Yes..I have 1 programmer that uses 4gl Interactive Debugger (FGLDB)! We do > have nearly 300,00 lines of code in 4gl. > > I think this is where the problem is. Totally my fault for not checking the > version before I installed FGLDB from Passport Advantage. I simply selected > the first Linux Version instead of the 7.50 UC5 version. > Engine: 11.50 UC8 > C4GL: 7.50 UC5 > ISQL: 7.50 UC5 > FGLDB: 7.32 UC1 > > I am thinking that the FGLDB install wiped something that IDS needs. Can I > reinstall all products except FGLDB to get the directories back to where > they > were? > > Thx for assistance. > > Chet > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --089e0118268001728204fdd5a4e5
Art, I tried to install the 7.50 version of FGLDB. I need to get glibc 2.5 or greater. I am going to try and get things working as there were before (which was very good), forego the FGLDB install for now and schedule a full upgrade of IDS and tookls together. Last question (I hope)..will the release of Red Hat (Release 4)that I am running work ok with the newer Informix Release?
Art, Do I need to run the uninstall scripts prior to the install scripts? Chet
No definite idea. It should but may not be officially certified. Don't know. Art Art S. Kagel, Principal Consultant ASK Database Management Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jul 10, 2014 at 8:14 AM, CHESLEY BRION <cjb16@cornell.edu> wrote: > Art, > > I tried to install the 7.50 version of FGLDB. I need to get glibc 2.5 or > greater. I am going to try and get things working as there were before > (which > was very good), forego the FGLDB install for now and schedule a full > upgrade > of IDS and tookls together. > > Last question (I hope)..will the release of Red Hat (Release 4)that I am > running work ok with the newer Informix Release? > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001a11c34b88b5764c04fdd60867
No. Art Art S. Kagel, Principal Consultant ASK Database Management Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Thu, Jul 10, 2014 at 8:23 AM, CHESLEY BRION <cjb16@cornell.edu> wrote: > Art, > > Do I need to run the uninstall scripts prior to the install scripts? > > Chet > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001a11c25f3cbc5e3f04fdd6097e
Art, I hate to keep bothering you. It seems that the error message (/etc/brand: error while loading shared libraries requires glic 2.5 0r later dynamic linker)is more involved. I receive it if I attempt to install the tools. Where do I go to get an updated dybnamic linker? If I need to take this dialogue off the forum, pls advise. Thx ..chet