Re: Hardware RAID vs OnLine Mirroring
Posted in 1998
Glyn_Balmer_at_erith@smtpgwy.supertension.com wrote: > > I have picked up on Dennis Harding's response regarding > Informix-OnLine and RAID. > > We are shortly upgrading our server, UNIX and OnLine engine to an ICL > (Fujitsu) Teamserver, SCO UNIX Openserver 5.0 and OnLine 7.2x. Our > intention (at this stage) is to use hardware RAID (5) (Mylex). We > shall have 5*4Gb disks, less 1 for RAID parity, giving 16Gb database > disk space. This will be raw disk. My questions are as follows :- (1) > Are there any known problems running OnLine 7.2x using raw disk and > hardware RAID ? (2) Would we be better off forgoing the hardware RAID > and using OnLine 7's mirroring ? > > Any comments, particularly in view of Dennis' comment ("In general, > Informix does not like RAID") would be very welcome. Personally I dislike RAID 5 for databases and for Informix in particular. 1) Writes are too slow 2) The RAID configuration is prone to replicating garbage caused by bad media. Because of the way parity data is calculated there is a possibility that hardware problems could be propagated. Since 5 drives depend on each other for error correction, an error in one drive on data that is infrequently read may become replicated to the other drives if one of them fails and has to be replaced. Then new parity values are calculated by reading the corrupted data and poof, garbage! With only two drives interdependent there is 80% lower risk of this happening. Sounds like an unlikely scenario? We had a farm of 600 drives (as 120 RAID 5 sets) on 13 Informix server machines and lost data on 7 of those machines from 30 RAID sets just that way. We now use RAID 10 (hardware Mirroring and Striped mirrored pairs). We would get 40% better write performance from the same five pair stripe sets as from the mirror but we have the flexability to configure 20 and 30 drive stripe sets giving better than 6-10X the write performance where needed. I like Informix mirroring but the System Administrators prefer to be able to manage the drives and replace bad ones without Informix being aware. Performance of the hardware mirror is supposed to be better also. BTW Informix CANNOT use a 16GB stripe or RAID set. You must be able, at the hardware/drive/OS level, to create 2GB or smaller, RAW devices for Informix to use from this large stripe. This is what we do under DG/UX the DG Clarion Manager can create the raw devices from the logical stripe any size we need. So we just divide the 240GB (30 drives x 8GB) stripe set into 120 2GB raw devices and use these. BWT be sure to size the stripes and partial devices such that each successive chunk begins on another drive, round robin, to avoid bottlenecking and make the stripe partition size (amount of data on each drive per segment) at least 8K so that Informix BIG WRITES can be written to a single physical drive. Art S. Kagel