sqlcode < 100
Posted in 1993
We're running SCO Unix 3.2.4 on 486 PCs with the 4.1 SE and 4.1 I-Net, plus 4.0 RDS front ends. All of a sudden we're getting a series of repetitive sqlerrs. This started happening immediately after we altered an unique index to start accepting duplicate values. Did this really have anything to do with these problems? Its looks like we need bump up some of our kernal parameters, but can someone tell us which ones? Here is an excerpt from our errlog: ... Date: 03/02/1993 Time: 16:01:23 Program error at "ad_field.4gl", line number 110. SQL statement error number -242. Could not open database table (root.stiinvtr). SYSTEM error number -113. Date: 03/02/1993 Time: 16:01:22 Program error at "fg_mesg.4gl", line number 138. SQL statement error number -211. Cannot read system catalog (systables). SYSTEM error number -46. Date: 03/02/1993 Time: 16:05:42 Program error at "fg_single.4gl", line number 989. SQL statement error number -240. Could not delete a row. SYSTEM error number -121. Date: 03/02/1993 Time: 16:18:19 Program error at "fg_funcs.4gl", line number 607. SQL statement error number -244. Could not do a physical-order read to fetch next row. SYSTEM error number -134. ... Once again, these same SQL (SYSTEM?) Errors just keep repeating. Someone once told me that errors < 100 are system errors, but I cannot remember how I could go about find out what they really are. Can anyone help? Since we're running I-Net, I would assume that these errors are caused by the parameters on the database server. We should therefore bump up the kernal parameters there, is this the correct assumption? Thanks in advance for any replies... Charles Lei Mediatech, Inc. E-Mail: lei@mediatech.com UUCP: ..!{uunet,4gen}!mtcdev!lei Voice: (312) 828-1146