RE: Informix 9.40 crash.
Posted in 2003
Topics: Error Codes & Troubleshooting, Logging & Checkpoints, Cloud, Docker & Containers
Hi Marino
can you pasted /tmp/af.40a1e72 this file
Regards
HITEN .S.BHAWSAR
Lawkim Pvt Ltd.
(A Godrej Company)
IBM - Informix Technical Helpdesk For Only AMC Customer in India.
Tell No:91022-25302255. Ext No :470.
Toll Free No: 1-600-11-7786.
If you have knowledge, let others light their candles with it
"This e-mail message may contain confidential, proprietary or legally
privileged information. It should not be used by anyone who is not the
original intended recipient. If you have erroneously received this message,
please delete it immediately and notify the sender. The recipient
acknowledges that Lawkim & its associated companies, are unable to exercise
control or ensure or guarantee the integrity of /over the contents of the
information contained in e-mail transmissions and further acknowledges that
any views expressed in this message are those of the individual sender and
no binding nature of the message shall be implied or assumed unless the
sender does so expressly with due authority of Lawkim Pvt.Ltd. Before
opening any attachments please check them for viruses and defects."
-----Original Message-----
From: Marino Decaro [mailto:dmvposta@hotmail.com]
Sent: Thursday, November 06, 2003 2:48 PM
To: informix-list@iiug.org
Subject: Informix 9.40 crash.
Hi all,
today the informix instance crashed.
The machine configuration is the following:
Informix Dynamic Server Version 9.40.FC1
Compaq Tru64 UNIX V5.1B (Rev. 2650)
And this is a part of online.log...
16:59:33 DR: Reservation of the last logical log for log backup turned on
16:59:33 Physical Recovery Started at Page (1:102061).
16:59:33 Physical Recovery Complete: 527 Pages Examined, 527 Pages
Restored.
16:59:33 Logical Recovery Started.
16:59:33 10 recovery worker threads will be started.
16:59:43 Fast Recovery Switching to Log 1008
16:59:46 Logical Recovery has reached the transaction cleanup phase.
16:59:46 Assert Failed: Rollback error 126
16:59:46 Informix Dynamic Server Version 9.40.FC1
16:59:46 Who: Session(17, root@deimos.icrcosmetics.local, 0, 22c3fec78)
Thread(34, fast_rec, 22c3baa58, 1)
File: rstrans.c Line: 2378
16:59:46 Results: Log record (OLDRSAM:HDELETE) in log 1008, offset0xd867f0 was not rolled back
16:59:46 Action: Use 'onlog' to view the transaction and repair manually.
16:59:46 stack trace for pid 650335 written to /tmp/af.40a1e72
16:59:46 See Also: /tmp/af.40a1e72
16:59:51 Rollback error 126
16:59:52 Assert Failed: Rollback error 126
16:59:52 Informix Dynamic Server Version 9.40.FC1
16:59:52 Who: Session(17, root@deimos.icrcosmetics.local, 0, 22c3fec78)
Thread(34, fast_rec, 22c3baa58, 1)
File: rsextlog.c Line: 1636
16:59:52 Results: Log record (OLDRSAM:HDELETE) in log 1008, offset0xd867f0 was not rolled back
16:59:52 Action: Use 'onlog' to view the transaction and repair manually.
16:59:52 stack trace for pid 650335 written to /tmp/af.40a1e72
16:59:52 See Also: /tmp/af.40a1e72
16:59:57 Rollback error 126
16:59:57 Assert Failed: Dynamic Server must abort
We cannot bring the system online: during the fast recovery it crash.
Is it possible to restart the system without the log 1008 or to drop this
log?
What does it means 'repair manually'? How can I do?
Can someone help to bring up the sistem however?
Thanks in advance.
Ciao.
Marino Decaro
sending to informix-list
Thank you, Hiten
Informix Technical Support has just resolved the problem: they deleted
manually the log 1008 and now the system is online.
Ciao.
Marino Decaro
"hiten.bhawsar" <hiten.bhawsar@litesindia.com> ha scritto nel messaggio
news:bof62l$4tp$1@terabinaries.xmission.com...
>
> Hi Marino
>
>
> can you pasted /tmp/af.40a1e72 this file
>
>
> Regards
> HITEN .S.BHAWSAR
> Lawkim Pvt Ltd.
> (A Godrej Company)
> IBM - Informix Technical Helpdesk For Only AMC Customer in India.
>
> Tell No:91022-25302255. Ext No :470.
> Toll Free No: 1-600-11-7786.
>
> If you have knowledge, let others light their candles with it
>
> "This e-mail message may contain confidential, proprietary or legally
> privileged information. It should not be used by anyone who is not the
> original intended recipient. If you have erroneously received this
message,
> please delete it immediately and notify the sender. The recipient
> acknowledges that Lawkim & its associated companies, are unable to
exercise
> control or ensure or guarantee the integrity of /over the contents of the
> information contained in e-mail transmissions and further acknowledges
that
> any views expressed in this message are those of the individual sender and
> no binding nature of the message shall be implied or assumed unless the
> sender does so expressly with due authority of Lawkim Pvt.Ltd. Before
> opening any attachments please check them for viruses and defects."
>
>
>
>
> -----Original Message-----
> From: Marino Decaro [mailto:dmvposta@hotmail.com]
> Sent: Thursday, November 06, 2003 2:48 PM
> To: informix-list@iiug.org
> Subject: Informix 9.40 crash.
>
>
> Hi all,
>
> today the informix instance crashed.
> The machine configuration is the following:
>
> Informix Dynamic Server Version 9.40.FC1
> Compaq Tru64 UNIX V5.1B (Rev. 2650)
>
> And this is a part of online.log...
>
> 16:59:33 DR: Reservation of the last logical log for log backup turned on
> 16:59:33 Physical Recovery Started at Page (1:102061).
> 16:59:33 Physical Recovery Complete: 527 Pages Examined, 527 Pages
> Restored.
> 16:59:33 Logical Recovery Started.
> 16:59:33 10 recovery worker threads will be started.
> 16:59:43 Fast Recovery Switching to Log 1008
> 16:59:46 Logical Recovery has reached the transaction cleanup phase.
> 16:59:46 Assert Failed: Rollback error 126
> 16:59:46 Informix Dynamic Server Version 9.40.FC1
> 16:59:46 Who: Session(17, root@deimos.icrcosmetics.local, 0, 22c3fec78)
> Thread(34, fast_rec, 22c3baa58, 1)
> File: rstrans.c Line: 2378
> 16:59:46 Results: Log record (OLDRSAM:HDELETE) in log 1008, offset> 0xd867f0 was not rolled back
> 16:59:46 Action: Use 'onlog' to view the transaction and repair
manually.
> 16:59:46 stack trace for pid 650335 written to /tmp/af.40a1e72
> 16:59:46 See Also: /tmp/af.40a1e72
> 16:59:51 Rollback error 126
> 16:59:52 Assert Failed: Rollback error 126
> 16:59:52 Informix Dynamic Server Version 9.40.FC1
> 16:59:52 Who: Session(17, root@deimos.icrcosmetics.local, 0, 22c3fec78)
> Thread(34, fast_rec, 22c3baa58, 1)
> File: rsextlog.c Line: 1636
> 16:59:52 Results: Log record (OLDRSAM:HDELETE) in log 1008, offset> 0xd867f0 was not rolled back
> 16:59:52 Action: Use 'onlog' to view the transaction and repair
manually.
> 16:59:52 stack trace for pid 650335 written to /tmp/af.40a1e72
> 16:59:52 See Also: /tmp/af.40a1e72
> 16:59:57 Rollback error 126
> 16:59:57 Assert Failed: Dynamic Server must abort>
>
> We cannot bring the system online: during the fast recovery it crash.
>
> Is it possible to restart the system without the log 1008 or to drop this
> log?
> What does it means 'repair manually'? How can I do?
> Can someone help to bring up the sistem however?
>
> Thanks in advance.
>
> Ciao.
> Marino Decaro
>
> sending to informix-list
hiten.bhawsar wrote: > Hi Marino > > can you pasted /tmp/af.40a1e72 this file No, please don't! It is likely to be huge and a massive drain on everyone's bandwidth. -- Ciao, The Obnoxious One "Ogni uomo mi guarda come se fossi una testa di cazzo"