9.4 and red hat 8.0 gotcha
Posted in 2004
HI All,
I thought I send in case any one would upgrade to these platforms.
Software > Support >
Checkpoints stuck, onstats fail, engine not responding on Red Hat Linux
Flashes
Abstract
Memory structures become corrupted when using TCP/IP connections on Red Hat
Linux 8.0. The corruption can cause various engine processes to stop
responding.
Content
PROBLEM
When using a TCP/IP connection, memory structures in IBM Informix Dynamic
Server (IDS) become corrupted. This can lead to many different symptoms
including the following:
Checkpoints remain in a blocked state for a long time. This usually occurs
when you try to run more than three queries at the same time.
The engine stops responding to requests (hangs).
When running onstat you get the following error:
Changing data structure forced command termination.
It is normal to get this error occasionally but if you get it persistently it
is a symptom of this problem.
Ontape stops responding (hangs) while restoring or creating an archive.
SCOPE
The following products and platforms are effected:
Product Name Product Version(s) Hardware Vendor Operating System
IBM Informix Dynamic Server (IDS) 9.40.UC1
9.40.UC2
All Red Hat Linux 8.0
kernel version 2.4.18-14
glibc version 2.2.93-5
CAUSE
The data table corruption occurs due to a TCP/IP problem found in the glibc
package shipped with Red Hat 8.0.
IMPACT
It is unlikely that this problem will cause data corruption, but some
operations performed by the engine may not complete. This could cause some
data to be lost.
SOLUTION
Upgrade the glibc package to version 2.3.2-4.80.6. The newer version of glibc
is available from Red Hat.
See the Related Information section below for two links to the library.
A fix for this problem will be included in 9.40.UC3.
This version has been released as of 01/19/2004