Getting ISAM error 116 during update statistics
Posted in 2006
Topics: Storage & Space Management, Error Codes & Troubleshooting, Server Administration
Hi
We are getting error code 116(ISAM) and 243(sqlcode) during an update
statistics command run on one of the column of a raw table. This problem is
specific to some servers. We do not what causes these kind of error. We
checked the ONCONFIG and set the same values in other different servers but
update statistics ran succesfully.
PDQ PRIORITY is set to ON during this update statistics.PFB the parametrs in
ONCONFIG
MAX_PDQPRIORITY 10
DS_MAX_QUERIES
DS_TOTAL_MEMORY
DS_MAX_SCANS 1048576
DATASKIP off
we are notable to find the cause of this problem. Please we need help on
this.
This error is coming in the particular informix instance.There are around
6-7 databases on this instance where same problem is coming. everywhere else
it is smooth.
rootdbs(sysmaster) is having nearly 10% of space still available.
Increase DS_TOTAL_MEMORY from the default and increase SHMVIRTSIZE to
accomodate
the extra memory. Also I'd advise setting DS_MAX_QUERIES to some small number
so that you can run more than one PDQ process at a time (unless you have only
one CPU VP configured).
Art S. Kagel
----- Original Message -----
From: Dd Mishra <ids@iiug.org>
At: 5/25 21:58:36
Hi
We are getting error code 116(ISAM) and 243(sqlcode) during an update
statistics command run on one of the column of a raw table. This problem is
specific to some servers. We do not what causes these kind of error. We
checked the ONCONFIG and set the same values in other different servers but
update statistics ran succesfully.
PDQ PRIORITY is set to ON during this update statistics.PFB the parametrs in
ONCONFIG
MAX_PDQPRIORITY 10
DS_MAX_QUERIES
DS_TOTAL_MEMORY
DS_MAX_SCANS 1048576
DATASKIP off
we are notable to find the cause of this problem. Please we need help on
this.
This error is coming in the particular informix instance.There are around
6-7 databases on this instance where same problem is coming. everywhere else
it is smooth.
rootdbs(sysmaster) is having nearly 10% of space still available.
*******************************************************************************
Forum Note: Use "Reply" to post a response in the discussion forum.
Thanks for all your support
this problem is solved by increasing the shared memory value in that server
:-)
On 5/26/06, ART KAGEL, .... <kagel@bloomberg.net> wrote:
>
>
> Increase DS_TOTAL_MEMORY from the default and increase SHMVIRTSIZE to
> accomodate
> the extra memory. Also I'd advise setting DS_MAX_QUERIES to some small
> number
> so that you can run more than one PDQ process at a time (unless you have
> only
> one CPU VP configured).
>
> Art S. Kagel
> ----- Original Message -----
> From: Dd Mishra <ids@iiug.org>
> At: 5/25 21:58:36
>
> Hi
>
> We are getting error code 116(ISAM) and 243(sqlcode) during an update
> statistics command run on one of the column of a raw table. This problem
> is
> specific to some servers. We do not what causes these kind of error. We
> checked the ONCONFIG and set the same values in other different servers
> but
> update statistics ran succesfully.>
> PDQ PRIORITY is set to ON during this update statistics.PFB the parametrs
> in
> ONCONFIG
> MAX_PDQPRIORITY 10
> DS_MAX_QUERIES
> DS_TOTAL_MEMORY
> DS_MAX_SCANS 1048576
> DATASKIP off>
> we are notable to find the cause of this problem. Please we need help on
> this.
>
> This error is coming in the particular informix instance.There are around
> 6-7 databases on this instance where same problem is coming. everywhere
> else
> it is smooth.
>
> rootdbs(sysmaster) is having nearly 10% of space still available.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>