How can I change the logging mode of a database ?
Posted in 1999
Topics: Backup & Restore, Platform-Specific Issues
I wont to chage the logging mode of my "mydatabase" to unbuffered
I use the command "ontape -s -U mydatabase", but it fails:
---> Invalid logging change to mydatabase
I use the command "ondblog buf mydatabase", without errors, but
don't make the change
I use Informix Online Dinamic Server (7.24) under Solaris 2.6
Any suggest ?
Thank in advance.
--
I haven't used this before, but in the SQL Syntax manual you'll find the
syntax for the "set log" command. With this command you can change your
logging from unbuffered to buffered and vice versa.
I hope this helps.
Regards
Dirk
Luis Miguel Martin <luismi@ubu.es> wrote in article
<378F25C3.1E422DD5@ubu.es>...
> I wont to chage the logging mode of my "mydatabase" to unbuffered
> I use the command "ontape -s -U mydatabase", but it fails:
> ---> Invalid logging change to mydatabase
>
> I use the command "ondblog buf mydatabase", without errors, but
> don't make the change
>
> I use Informix Online Dinamic Server (7.24) under Solaris 2.6
> Any suggest ?
> Thank in advance.
>
> --
>
>
In article <378F25C3.1E422DD5@ubu.es>,
Luis Miguel Martin <luismi@ubu.es> wrote:
>I wont to chage the logging mode of my "mydatabase" to unbuffered
>I use the command "ontape -s -U mydatabase", but it fails:
> ---> Invalid logging change to mydatabase
>
>I use the command "ondblog buf mydatabase", without errors, but
>don't make the change
There are some logging mode changes that cannot be made. For example,
if a database is using ANSI logging mode, all changes will be refused.
Check the admin manual for all the gory details. (The admin manuals are
an Informix administrator's best friend. However, like all friends,
they have their flaws, and occasionally you will stumble upon one. This
does not make them worthless.)
Jim
--
W. Jim Jordan, Nortel Networks, Stop 29CA3A08 | +1 613 763 1568
PO Box 3511 Stn C, Ottawa, ON K1Y 4H7 Canada | wjjordan@nortelnetworks.com
Opinions expressed are not necessarily those of Nortel Networks.
Inbound spam filtering is in place. Don't send what I won't see.