program failing in secondary server
Posted in 2009
Topics: High Availability & Replication
Hi. In a SDS environment there is a difference between inserts and puts. In the primary instance the program works correctly but in the secondary it fails with and trying to insert null value in a column that don't accept nulls.
This must be a translation error. You are saying that you cannot insert a NULL into a NOT NULL column on an SDS secondary but you can on the primary? That doesn't sound right at all. Also, what's different between a singleton INSERT and PUTing to an INSERT CURSOR? Please do your best to be specific and clear. If you are having trouble, post in a language with which you are more comfortable and someone will translate for the rest of us. Art Art S. Kagel Oninit (www.oninit.com) IIUG Board of Directors (art@iiug.org) Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Oninit, the IIUG, nor any other organization with which I am associated either explicitly or implicitly. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Tue, Jul 21, 2009 at 12:04 AM, Juan Jose Rodriguez < juan.rodriguez@ieee.org> wrote: > Hi. > > In a SDS environment there is a difference between inserts and > puts. In the primary instance the program > works correctly but in the secondary it fails with and trying to > insert null value in a column that don't accept > nulls. > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001636c5a44027b109046f35b9ab
Hi Second try. scenario one: Program runs in the primary instance and every thing is correct. All inserts work. scenario two: Program runs in the secondary instance and fails with a not null constraint violation. The table is empty and the program tried to insert eighth rows before the error. In both scenarios the data is the same. I thought that the secondary instance had some limitation about the insert cursor (PUTing) but I was wrong. And my other hypothesis is that some value is considered null in the secondary but in the primary is considered not null. Hope this time I'm clear. =) > -----Original Message----- > From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Art Kagel > Sent: Tuesday, July 21, 2009 6:41 AM > To: ids@iiug.org > Subject: Re: program failing in secondary server [16463] > > This must be a translation error. You are saying that you cannot insert a > NULL into a NOT NULL column on an SDS secondary but you can on the primary? > That doesn't sound right at all. Also, what's different between a singleton > INSERT and PUTing to an INSERT CURSOR? Please do your best to be specific > and clear. If you are having trouble, post in a language with which you are > more comfortable and someone will translate for the rest of us. > > Art > > Art S. Kagel > Oninit (www.oninit.com) > IIUG Board of Directors (art@iiug.org) > > Disclaimer: Please keep in mind that my own opinions are my own opinions and > do not reflect on my employer, Oninit, the IIUG, nor any other organization > with which I am associated either explicitly or implicitly. Neither do > those opinions reflect those of other individuals affiliated with any entity > with which I am affiliated nor those of the entities themselves. > > On Tue, Jul 21, 2009 at 12:04 AM, Juan Jose Rodriguez < > juan.rodriguez@ieee.org> wrote: > >> Hi. >> >> In a SDS environment there is a difference between inserts and >> puts. In the primary instance the program >> works correctly but in the secondary it fails with and trying to >> insert null value in a column that don't accept >> nulls. >> >> >> >> > ******************************************************************************* >> Forum Note: Use "Reply" to post a response in the discussion forum. >> >> > > --001636c5a44027b109046f35b9ab > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. >
MUCH clearer. Sounds like a bug. Open a case with IBM. Art Art S. Kagel Oninit (www.oninit.com) IIUG Board of Directors (art@iiug.org) Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Oninit, the IIUG, nor any other organization with which I am associated either explicitly or implicitly. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Tue, Jul 21, 2009 at 10:51 PM, Juan Jose Rodriguez < juan.rodriguez@ieee.org> wrote: > Hi > > Second try. > > scenario one: > > Program runs in the primary instance and every thing is > correct. All inserts work. > > scenario two: > > Program runs in the secondary instance and fails with a not > null constraint violation. The table is empty and the program tried to > insert eighth rows before the error. > > In both scenarios the data is the same. > > I thought that the secondary instance had some limitation about the > insert cursor (PUTing) but I was wrong. > > And my other hypothesis is that some value is considered null in > the secondary but in the primary is considered not null. > > Hope this time I'm clear. =) > > > -----Original Message----- > > From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of > Art > Kagel > > Sent: Tuesday, July 21, 2009 6:41 AM > > To: ids@iiug.org > > Subject: Re: program failing in secondary server [16463] > > > > This must be a translation error. You are saying that you cannot insert a > > NULL into a NOT NULL column on an SDS secondary but you can on the > primary? > > That doesn't sound right at all. Also, what's different between a > singleton > > INSERT and PUTing to an INSERT CURSOR? Please do your best to be specific > > and clear. If you are having trouble, post in a language with which you > are > > more comfortable and someone will translate for the rest of us. > > > > Art > > > > Art S. Kagel > > Oninit (www.oninit.com) > > IIUG Board of Directors (art@iiug.org) > > > > Disclaimer: Please keep in mind that my own opinions are my own opinions > and > > do not reflect on my employer, Oninit, the IIUG, nor any other > organization > > with which I am associated either explicitly or implicitly. Neither do > > those opinions reflect those of other individuals affiliated with any > entity > > with which I am affiliated nor those of the entities themselves. > > > > On Tue, Jul 21, 2009 at 12:04 AM, Juan Jose Rodriguez < > > juan.rodriguez@ieee.org> wrote: > > > >> Hi. > >> > >> In a SDS environment there is a difference between inserts and > >> puts. In the primary instance the program > >> works correctly but in the secondary it fails with and trying to > >> insert null value in a column that don't accept > >> nulls. > >> > >> > >> > >> > > > > ******************************************************************************* > >> Forum Note: Use "Reply" to post a response in the discussion forum. > >> > >> > > > > --001636c5a44027b109046f35b9ab > > > > > > > > ******************************************************************************* > > Forum Note: Use "Reply" to post a response in the discussion forum. > > > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --001636c5a8d1d6d04e046f49a29d