Re: onbar error message
Posted in 2004
On Wed, 26 May 2004 10:00:51 -0400, Davorin Kremenjas wrote:
It may be that during that time, there is a long transaction running which is
not permitting the backed up logical logs to be released for reuse. If you
can determine that this is the case (run onstat -l perhaps from a cron
periodically or using the -r option to see if this is happening) then you
need to do two things:
- Increase the size or number of logical logs to accomodate these large
transactions, and/or
- Recode the tasks that are performing these huge transactions to break them
into smaller logical pieces to reduce the dependency on log space and reduce
recovery time in case of a crash.
Art S. Kagel
> Hello!
> I have an Informix backup configured as an onbar + Legato Networker
> combination with IDS 9.40 UC3 on Solaris 9 machine. We take dbspace backups
> every night and continously backup logical logs using log_full.sh script.
> All works well except one thing: if logical logs start to fill very quick
> (around 50 logs in 2 minutes) error messages start to appear in bar_act.log:
>
> "The logical logs are full. ON-Bar may encounter errors writing to the
> sysutils database."
>
> Weird thing is that logs do back up, which can also be seen from
> bar_act.log:
>
> ...
> 2004-05-26 04:15:17 29921 29919 Begin backup logical log 9234. 2004-05-26
> 04:15:18 29976 29974 /usr/informix/bin/onbar_d -b -l 2004-05-26 04:15:18
> 29921 29919 Completed backup logical log 9234 (Storage Manager copy ID:
> 1085537717 1085537720). 2004-05-26 04:15:18 29921 29919 Begin backup
> logical log 9235. 2004-05-26 04:15:18 29976 29974 A log backup is already
> running. Can't start another.
> 2004-05-26 04:15:19 29921 29919 The logical logs are full. ON-Bar may
> encounter errors writing to the sysutils database. 2004-05-26 04:15:19 29921
> 29919 Completed backup logical log 9235 (Storage Manager copy ID:
> 1085537718 1085537722). 2004-05-26 04:15:19 29921 29919 Begin backup
> logical log 9236. ...etc...
>
>
> I thought of increasing the size of logs so they don't fill up so quickly
> but I'm not sure whether it will solve the problem. At this moment onconfig
> looks like this:
>
> # Logical Log Configuration
> LOGFILES 256 # Number of logical log files LOGSIZE
> 512 # Logical log size (Kbytes)>
> The reason why the logs start to fill so quickly is that we have update
> statistics for tables and procedures run every morning at 04:15.
>
> Any ideas?
> Thanks everyone.