Re: New reserved word?
Posted in 1994
ete@trac3000.ueci.com (Eliot Everingham) writes:
>I'm running 4.12. ISQL and 5.02. Online for OSF/1 v2.0 and having a problem
>that seems to be caused by the use of a reserved word. The following SQL
>statement produces a syntax error (the same statement works fine if "primary"
>is changed to some other, unreserved word).
>create table foo (primary char(1));
>Can anyone verify this? Does the syntax error generated by the use of the
>reserved word come from ISQL, or from the engine?
"primary" is a reserved word for use in the syntax "primary key". This
is used by the engine for declaritive referential integrity in versions 5.0
and later.
- David
>Thanks.
>- Eliot
>--
>"I sold a quart of blood and bought a half a pint of scotch" - Tom Waits
>Eliot Everingham - Raytheon Engineers and Constructors - ete@trac3000.ueci.com