Installing informix on RH Linux (5.2)
Posted in 1999
Topics: Installation, Setup & Upgrades, Platform-Specific Issues, Versions, Editions & End-of-Life
I'm working on installing IDS 7.30 on my Linux box here. And I'm trying to run the installserver script. I already had to alter it to get it to run (change the parameters on "test" to make it see that I have in fact set $INFORMIXDIR), but now it gets to where it starts installing and does: Installing directory . Installing directory aaodir Installing directory bin Unknown error message number '32766' Installation of Informix Dynamic Server failed. Anybody run into similar problems or have clues as to where I would look to track this down? thanks, Jesse Kipp p.s. Please cc me with any replies, and the news feed in my region of the net is really bad.
Alright... never mind. I'm an idiot... it was late. I got my problem solved. :) thanks, Jesse
Jesse Kipp wrote: > > I'm working on installing IDS 7.30 on my Linux box here. And I'm > trying to run the installserver script. I already had to alter it > to get it to run (change the parameters on "test" to make it see > that I have in fact set $INFORMIXDIR), but now it gets to where it > starts installing and does: > > Installing directory . > Installing directory aaodir > Installing directory bin > Unknown error message number '32766' > Installation of Informix Dynamic Server failed. This indicates that you have not set $INFORMIXDIR properly. Did you set it without exporting it? Which shell are you using? > Anybody run into similar problems or have clues as to where I > would look to track this down? Are you sure that if you type: env that your INFORMIXDIR is set correctly? And is it where you placed the extracted files? The default location is /opt/informix unless you used --relocate or equivalent on RPM. So INFORMIXDIR should be set to /opt/informix or whatever. If that is set and does not work, then I recommend deleting what you've installed with RPM, then removing the directory completely, and then starting over. The error message 32766 is the absolute classic indication that INFORMIXDIR is either not set or is set to completely the wrong place. -- Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net) Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN #include <disclaimer.h>