Re: Replication 7.11
Posted in 1997
In article <5dabil$rct@cssun.mathcs.emory.edu>, Con Woodall <cwoodall@vt
h4.vth.colostate.edu> writes
>Perhaps you have been here and can shed some light.
>
>Running Online 7.11.uc1 under AIX 3.2.5.
>
>We had replication running successfully for several weeks. An AIX
>change intended to affect only the physical IP address of the secondary
>machine has left us with several problems. When we initialize the
>secondary with ontape -p using the archive from the primary, we are
>shown two warnings in the online.log file
>
>13:29:59 WARNING! Physical Log size 0 is too small.> Physical Log overflows may occur during peak activity.
> Recommended minimum Physical Log size is 20 times maximum
> concurrent user threads.
>
>13:29:59 WARNING! Logical log layout may cause OnLine to get into> a locked state. Recommended smallest logical log size
> is 2 times maximum concurrent user threads.
>
Try tbstat -c to get the current configuration on the seconary BEFORE
ontape -p and check it matches the primary configuration with only the root dbspace and temporary dbspaces including (dbspace has a
T against in in onmonitor).
Something seems wrong. Perhaps you forgot to create the required
temporary dbspaces before doing ontape -p. These are ones where
Temp? is set to "Y" in onmonitor when creating them.
>Now, these warnings do not seem to impede the process of replication.
>It goes on just fine, but I can find nothing different in the
>relationship of the two servers in environment variable, onconfig,
>sqlhosts and the /etc/hosts and /services files. The disk space allocations
>on both systems are unchanged and we did not get the warnings before.
>
>I would be tempted to ignore the warnings if it were not for the other
>changed situation. When running an onmode -d command that actually
>makes the replication connection on the secondary, the online.log file
>reports the following error.
>
>15:31:46 Warning: Invalid dbspace 'rtemp1_dbspace' listed in DBSPACETEMP.
Yes- sounds like a temporary dbspace was not created on the secondary
before ontape -p was done.
>
>The designation of temp space is correct and unchanged and matches
>that of the primary machine and this warning did not appear in the
>earlier successful replication.
>
>However, replication goes on, BUT if I attempt to access the secondary
>server remotely (i.e. connecting to the replicated instance under
>dbaccess.), I can create no temp tables. Error 229 says it could not
>create a temporary file and references error 131 which says there is no
>free disk space. I can run select and order by and group by, but no temp
>tables.
Again this seems the problem.
>
>If you have any experience with having chased this problem down, I
>would apprectate any insight you can give.
>
>Thanks in advance.
>
--
David Williams