Re: Logical logs filling up - blocks whole server
Posted in 1999
Ben, The reason the server blocks is to allow you to backup your logs. If you don't backup your logs you will lose your recoverability. If you don't care about your recoverability, then just backup all of you logs to /dev/null. If you have no more space to log transactions where would you expect your transaction information to go if there was a setting to not block the server. Would you want to overwrite non-backed up logs, highly unlikely that Informix will ever add a switch to do this. Overall, fix you backup problem. Greg Ben Gould wrote: > In article <uwvs6tpi8.fsf@ose.no>, Thomas Parsli <thomas.parsli@ose.no> > wrote: > > > Ben Gould <ben.gould@none.net> writes: > > > > > Hello > > > > > > We're having problems with some backup procedures that are not as > > > reliable as we want them to be. > > > > > > I've got sql code that is running a bulk import and sometimes we're > > > having failures with our backup system which mean that the informix > > > server blocks all sql commands until logical logs get backed up and > > > cleared down. > > > > If you have enough logs (in count and size) this shouldn't be a problem > > -if you continously back them up. > > yes we have enough logs > > however there's a problem with our continuous backup - which should > work ok and has done in the past - which is being looked into at the > moment - but sometimes fails. > > I want to find a way of avoiding the problem where the entire server > locks up as I need a quick response on success or failure - not the > entire statement to hang execution. > > Regardless of whether backup works reliably in the future I don't want > to see this problem hang execution so am looking for either a server > configuration parameter that will tell Informix 9.14.UC6 to not block > and report an error or some way that this can be set on a connection by > connection level from SQL. > > -- ben