INFORMIX error -837 in MS Windows -- makes no sense
Posted in 1993
We have been having a random but persistent problem with what appears to be bogus -837 errors appearing on our MS Windows machines. This error purports to be an out-of-memory error. However, we are using 486 machines with 8MB real RAM and plenty of swap space. Furthermore, system sniffing utilities (e.g. SysUse13) indicate that there is indeed no impending crisis of memory, be it global heap or resources or whatever. One person claims that they can cold boot their system and bring up the INFORMIX application and sometimes it gets -837 and sometimes it don't. When these errors appear, they are *always* associated with the initial OPEN DATABASE (or equivalent) call. Once connected to a database, no further errors are ever posted. From an application standpoint, we are running PowerBuilder apps as well as PowerViewer. I believe the problem has been spotted in PowerBuilder 2.0 as well as the often-denegrated 3.0. The PCs in question are connected via INFORMIX-NET (INET) to a SUN server using FTP Inc.'s PC/TCP package. However, at least one user has reported the same error from a local INFORMIX database, Sometimes the PowerSoft app can be shut down, several other apps shut down, and then restarted without getting the -837. Other times the -837 is persistent and requires some warm/cold boot to dislodge it. For the record, REMSQL reports itself as version 4.10.DC1, and all other INFORMIX components seem to be synchronized from that release as well. Would appreciate any net.clues that you might have. Victor R. Volkman, Senior Analyst