Re[2]: dbschema from 7.22 to 5.05
Posted in 1999
Topics: Connectivity: ESQL/C, 4GL & Embedded SQL
I have ftped extraced the myschema.ec, but when I try to compile it
using wesql or wesqlc, it gives me the foll. errors :
INFORMIX-ESQL Version 5.01.WJ2
c:\\tms\\myschema.ec
esqlc: "c:\\tms\\myschema.ec", line 328: Error -33051: Syntax error on
identifier or symbol '#'.
esqlc: "c:\\tms\\myschema.ec", line 545: Error -33200: Invalid statement
on symbol 'CONNECT'.
esqlc: "c:\\tms\\myschema.ec", line 545: Error -33051: Syntax error on
identifier or symbol ':'.
esqlc: "c:\\tms\\myschema.ec", line 563: Error -33040: Object 'database'
was not declared.
esqlc: "c:\\tms\\myschema.ec", line 600: Error -33040: Object
'statement' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 656: Error -33040: Object 'database'
was not declared.
esqlc: "c:\\tms\\myschema.ec", line 665: Error -33040: Object 'ntables'
was not declared.
esqlc: "c:\\tms\\myschema.ec", line 689: Error -33040: Object 'database'
was not declared.
esqlc: "c:\\tms\\myschema.ec", line 711: Error -33040: Object
'pagecounts' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 741: Error -33040: Object 'database'
was not declared.
esqlc: "c:\\tms\\myschema.ec", line 773: Error -33040: Object
'statement' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 890: Error -33040: Object
'tablename' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 910: Error -33040: Object
'tablename' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 937: Error -33040: Object
'statement2' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 990: Error -33040: Object
'statement' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 1046: Error -33040: Object
'statement' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 1189: Error -33040: Object
'tablename' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 1671: Error -33051: Syntax error on
identifier or symbol 'INTO'.
esqlc: "c:\\tms\\myschema.ec", line 1847: Error -33040: Object
'statement' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 2498: Error -33040: Object
'tablename' was not declared.
esqlc: "c:\\tms\\myschema.ec", line 2890: Error -33040: Object
'tablename' was not declared.
21 error(s) found
Pls advise where am I going wrong. I am trying to compile this on my
client machine whicgh has New-Era 2.12 loaded.
Vandana
______________________________ Reply Separator _________________________________
Subject: Re: dbschema from 7.22 to 5.05
Author: <kagel@bloomberg.net > at aflgate
Date: 3/9/99 5:47 PM
Vandana R. Chadha wrote:
>
> Hello,
>
> We want to download a schema from ver 7.22 to ver 5.05 of Informix.
> Problem is that the schema in ver 7.22 has a constraint for every
> not-null column. Hence the sql gives syntax error if I load it in ver
> 5.05. Is there a way out by which I can create the scema sql in ver
> 7.22 without the constrain names for the not-null columns?
Get my myschema.ec utility from the IIUG Software Repository in the
package utils2_ak. It converts those nasty NOT NULL CONSTRAINTs to
simple NOT NULL clauses among other goodies like being able to schema
a database without trying to lock the tables.
Also watch for a new release of myschema in a week or two. New
features and a bug fix related to large views.
Art S. Kagel
Vandana R. Chadha wrote:
>
> I have ftped extraced the myschema.ec, but when I try to compile it
> using wesql or wesqlc, it gives me the foll. errors :
>
> INFORMIX-ESQL Version 5.01.WJ2
> c:\\tms\\myschema.ec
> esqlc: "c:\\tms\\myschema.ec", line 328: Error -33051: Syntax error on
> identifier or symbol '#'.
> esqlc: "c:\\tms\\myschema.ec", line 545: Error -33200: Invalid statement
> on symbol 'CONNECT'.
> [...]
> esqlc: "c:\\tms\\myschema.ec", line 2890: Error -33040: Object
> 'tablename' was not declared.
> 21 error(s) found
>
> Pls advise where am I going wrong. I am trying to compile this
> on my client machine whicgh has New-Era 2.12 loaded.
The problem is that myschema.ec uses the CONNECT statement introduced
in ESQL/C 6.00, and your 5.01 ESQL/C compiler does not understand it.
You'll have to modify myschema.ec to use a DATEBASE statement instead
of CONNECT, but there may be more to worry about than that.
> Subject: Re: dbschema from 7.22 to 5.05
> Author: <kagel@bloomberg.net > at aflgate
> Date: 3/9/99 5:47 PM
>
> Vandana R. Chadha wrote:
> > We want to download a schema from ver 7.22 to ver 5.05 of
> > Informix.
> > Problem is that the schema in ver 7.22 has a constraint for every
> > not-null column. Hence the sql gives syntax error if I load it in ver
> > 5.05. Is there a way out by which I can create the scema sql in ver
> > 7.22 without the constrain names for the not-null columns?
>
> Get my myschema.ec utility from the IIUG Software Repository in the
> package utils2_ak. It converts those nasty NOT NULL CONSTRAINTs to
> simple NOT NULL clauses among other goodies like being able to schema
> a database without trying to lock the tables.
>
> Also watch for a new release of myschema in a week or two. New
> features and a bug fix related to large views.
>
> Art S. Kagel
>
--
Jonathan Leffler (jleffler@informix.com, jleffler@earthlink.net)
Guardian of DBD::Informix v0.60 -- see http://www.perl.com/CPAN
#include <disclaimer.h>