Physical Log size 2000 is too small
Posted in 2014
Topics: Stored Procedures & SPL, Server Administration, Logging & Checkpoints
Hi,
Good Day
We are receiving an error when initializing the informix instance
Physical Log size 2000 is too small.
the command onparams -p -s 2000 was ran on the server and when is was
restarted the error above was displayed. The problem is that we cannot again
issue an onparams command since we cannot initialize the database. We also
tried to edit the onconfig PHYFILE to a larger number and tried to restart the
server (machine) then initialize the informix instance to no avail. What
should we do next to make the database operational again?
Lester, You did not mention the Informix version? What is the size of rootdbs? As physical log is initially created in rootdbs it should be small, later you must move it to a new dbspace. I believe your server is online and this is just a warning you are receiving? Try moving the physical log to new dbspace.
Hi Sorry forgot to include the informix version (11.7 FC7) No the server is not online and cannot be put online that is why we cannot issue any informix related commands. The rootdbs size in the onconfig is 32000 KB. Below was seen in the log of informix when trying to initialize informix 14:36:33 Memory sizes:resident:454816 KB, virtual:50352 KB, no SHMTOTAL limit 14:36:33 Logical Recovery has reached the transaction cleanup phase. 14:36:33 Performance Advisory: The physical log is running out of room during checkpoint processing. 14:36:33 Results: Transactions are being blocked until the checkpoint is complete. 14:36:33 Action: Increase the physical log size. 14:36:33 invoke_alarm(): /bin/sh -c '/inf/informix/etc/inf_log_full1.sh 5 21 "Dynamic Server resource overflow: 'PLog'." "Physical log file overflow" "/inf/informix/tmp/af.3eff170" 21004' 14:36:33 invoke_alarm(): mt_exec failed, status 32512, errno 0 14:36:33 Assert Failed: Physical log file overflow 14:36:33 IBM Informix Dynamic Server Version 11.70.FC7 14:36:33 Who: Session(1, informix@LOANS, 0, 7000000203a6028) Thread(7, main_loop(), 700000020364028, 1) File: rsbuff.c Line: 3996 14:36:33 Results: Dynamic Server must abort 14:36:33 Action: Reinitialize shared memory 14:36:33 stack trace for pid 8912954 written to /inf/informix/tmp/af.3eff170 14:36:33 See Also: /inf/informix/tmp/af.3eff170, shmem.3eff170.0 14:36:39 rsbuff.c, line 3996, thread 7, proc id 8912954, Physical log file overflow. 14:36:39 invoke_alarm(): /bin/sh -c '/inf/informix/etc/inf_log_full1.sh 5 6 "Internal Subsystem failure: 'MT'" "rsbuff.c, line 3996, thread 7, proc id 8912954, Physical log file overflow." "" 6500' 14:36:39 invoke_alarm(): mt_exec failed, status 32512, errno 0 14:36:39 PANIC: Attempting to bring system down
Hi,
You could try PLOG_OVERFLOW_PATH ...
http://www-01.ibm.com/support/knowledgecenter/SSGU8G_11.70.0/com.ibm.adref.doc/i
ds_adr_0135.htm
Once (if) the engine comes online, obviously change the Physical Log to a
decent size.
I wonder how you shut the engine down? onmode -ky OR onmode -uky? I would
always suggest onmode -uky - no open transactions on startup means recovery is
from a "no open transactions" state. (You have a bit of time on shutdown, but
startups are generally "do it quick!")
Hi,
the onconfig we are using is from a inf version 9.7 wherein no
PLOG_OVERFLOW_PATH located in it. I tried adding it to the onconfig and put a
location but the inf instance when restarted still always fails. As for the
onmode command we are always using onmode -ky maybe it's better if we use
onmode -uky from now on