IDS 7.30.UC6 crash
Posted in 1999
Dear Informixers,
my development engine (luckily not the production one) has been giving
me a strange error since it had to be reinitialized due to a harddisk
crash a couple of days ago.
The following message appears in the log file:
Wed Sep 29 14:40:58 1999
14:40:58 Event alarms enabled. ALARMPROG =
'/opt/7_informix/etc/no_log.sh'
14:41:10 DR: DRAUTO is 0 (Off)
14:41:10 Requested shared memory segment size rounded from 588KB to 592KB
14:41:11 Assert Failed: Condition Failed (Bad allocation size (0) forpool 'aio
' (0x21020018)), In (mt_shm_malloc_segid)
14:41:11 Informix Dynamic Server Version 7.30.UC6
14:41:11 Who: Session(0, @, 0, 0)
Thread(6, vp 1, 0, 7)
File: mtshpool.c Line: 2352
14:41:11 Action: Please notify Informix Technical Support.
14:41:30 See Also: /tmp/af.608e7, shmem.608e7.0
14:41:32 Assert Failed: Condition Failed (Bad allocation size (0) forpool 'aio
' (0x21020018)), In (mt_shm_malloc_segid)
14:41:32 Informix Dynamic Server Version 7.30.UC6
14:41:32 Who: Session(0, @, 0, 0)
Thread(6, vp 1, 0, 7)
File: mtshpool.c Line: 2352
14:41:32 Action: Please notify Informix Technical Support.
14:41:50 See Also: /tmp/af.608e7, shmem.608e7.1
14:42:09 Informix Dynamic Server Version 7.30.UC6 Software SerialNumber AAC#
J288479
14:42:20 Informix Dynamic Server Initialized -- Complete DiskInitialized.
14:42:21 Checkpoint Completed: duration was 0 seconds.
14:42:21 Dataskip is now OFF for all dbspaces
14:42:22 Quiescent Mode
14:43:03 On-Line Mode
14:43:03 Building 'sysmaster' database ...
14:44:01 Checkpoint Completed: duration was 4 seconds.
14:44:15 Logical Log 1 Complete.
14:45:02 Logical Log 2 Complete.
14:45:05 Checkpoint Completed: duration was 2 seconds.
14:45:40 'sysmaster' database built successfully.
14:45:41 'sysutils' database built successfully.
As you can see, the error happened immediately upon initializing the
engine and disk structures, even before anybody was using the system.
I never noticed this until I started getting "file system full" errors
today and found /tmp full of "shmem..." files. It turned out that
the same error occured several times yesterday and today, each time
dumping its shared memory into /tmp.
Any ideas where this might come from? I'll save some of the /tmp/af files
in case anyone wants to take a look.
Platform is Siemens Reliant UNIX 5.43C20, engine version is IDS 7.30.UC6
on a Siemens RM400-330. I cannot ask tech support right now because of
a problem with our support contract (nobody can locate the contract
number for the development machine, luckily it is intact for our
production server).
Regards, Richard
--
+----------------------------+-------------------------------------------+
| Dr. Richard Spitz | INTERNET: spitz@ana.med.uni-muenchen.de |
| EDV-Gruppe Anaesthesie | Tel : +49-89-7095-6110 |
| Klinikum Grosshadern | FAX : +49-89-7095-6420 |
| 81366 Munich, Germany | GSM : +49-172-8933578 |
+----------------------------+-------------------------------------------+