Re: tbcheck fails with coredump
Posted in 1997
Milen Metodiev wrote:
>
> Hello guys,
>
> After our last crash of Informix database, when user after entering in
> critical section didn't leave it, tbcheck utility started to coredump
> after running:
>
> $ tbcheck -cD <databaseName>>
> When ran
>
> $ tbcheck -cd <databaseName>>
> and there wasn't any problems.
>
> "The -cD performes the same checks as -cd but includes dbspace blob pages
> if any extsts" is written in the administrator's guide. So it seems that the
> problem is in the blobs. We have only one table with blobs and we checked it
> separately:
>
> $ tbcheck -cD <databaseName:table_with_blobs>>
> and there wasn't any problems again.
>
> Is that a tbcheck bug? How we can be sure that our data are correct and
> we'll have no any problems with applications and Informix server at all.
Yes. Tbcheck was broken for many specific problems until R5.06, blobs
(-cD) was one, extents (-pe) for large systems with blobspace blobs was
another. You will need to upgrade. For now the only solution, if
errors are uncovered will be to unload the table (avoid using indexes in
the unload ie do "WHERE 1=1").
Art S. Kagel