Re: 7 vs 9
Posted in 2004
rotor wrote: > Hi community! > Explain please difference. ESQL/C fragment: > > $EXECUTE IMMEDIATE "BEGIN WORK"; > $EXECUTE IMMEDIATE "CREATE TEMP TABLE lvo ( i INT, f char( 16 ) ) > WITH NO LOG"; > $EXECUTE IMMEDIATE "INSERT INTO lvo VALUES ( 1, 'A' )"; > $DECLARE sel CURSOR WITH HOLD FOR SELECT f INTO :f FROM lvo; > $OPEN sel; > $FETCH sel; > $EXECUTE IMMEDIATE "ROLLBACK"; > $EXECUTE IMMEDIATE "BEGIN WORK"; > $EXECUTE IMMEDIATE "CREATE TEMP TABLE lvo ( id INT ) WITH NO LOG"; > $EXECUTE IMMEDIATE "CREATE INDEX lvo ON lvo( id )"; > > This fragment works on 7.x without any problems. But on 9.x the last > statement fails with sql error -242 (isam -106). Please response who > knows why the difference exists and which server has bug. > > Regards, > rotor. > The -131 tells the tail. That's the ISAM level error and it says there's not enough disk space to build the index. That could be space for the index itself or, more likely, not enough sort-work space in your temp dbspaces or the filesystems specified in PSORT_DBTEMP for sorting the keys prior to building the BTREE. Art S. Kagel