Re: NLS database and MS Access
Posted in 1996
Koen.VanderElst@ping.be (Koen Van der Elst) wrote:
:On 25 Jul 1996 12:28:17 -0400, edmar@svb.nl ("Edmar Schut") wrote:
:>I am experimenting a little with MS-Access 7, Openlink ODBC and On-line 7.13.
:>When I create a database with NLS enabled and I want to access this
:>database via the ODBC-driver with user informix I get an error message
:>saying the LANG or LC_COLLATE var probably wasn't set correctly.
:>When I access the same database with dbaccess all works fine, but
:>then of course I defined the vars in my .profile.
:>How do I set these vars from the ODBC-driver. Am I missing something
:>here?
:>THA,
:On your UNix server, make sure you created the NLS database with the
:Unix environment variable not set to C ! Set it to something like
:english_us.8859 (check you System Adminstarors Guide).
:On the client side make sure that the following I-Net parameters are
:set : DbNls to 2 and CollChar to 1. To set these, run Setnet, chose
:the [more] button, then you can adjust these parameters.
Using I-Net will not help much (he probably even do not have it as he
is using OpenLink).
Where do you get the error message (in MS-Access or on your server
(Unix machine???)), and what is it in detail?
I haven't tested this yet, but I assume you have to make sure the LANG
and LC_COLLATE variables, as well as all other relevant environement
variables for Informix, are set correctly when you start the request
broker (oplrqb) on your unix machine.
If this doesn't work please tell us and in any case please post when
this is resolved. We need to do it shortly as well.
Nils.Myklebust@ccmail.telemax.no
NM Data AS, P.O.Box 9090 Gronland, N-0133 Oslo, Norway
My opinions are those of my company