Re: Problems with migration b/w 7.12 and 7.30
Posted in 1998
Let's hope I understood the problem. You could try:
1. Get the maximum value for your serial column from
your table -> MAXS
2. Try to insert in this table a record with the serial
column value set to MAXS+1.
Although I'm not sure it will help, but you could try.
Kind Regards,
Octav
Greg McGregor wrote:
>All,
>
>Having some problems migrating data from Informix 7.12 UC3 to
>an Informix 7.30 UC2.
>
>Firstly, performing a dbexport of a db from 7.12 environment and dbimporting into
>a 7.30 environment. As I'm aware there is no clear path to migrate b/w 7.12 and 7.30 therefore why my choice of tool for migration.
>One of the tables within the db being migrated has a field which is of type serial. It just so
>happens that any new row insert into this table fails with a 239 error - duplicate key.
>
>This table has three indices, two unique and one duplicate. I have verified the two unique
>indices are definitely not causing any problems.
>
>I need some advice on this problem.
>
>TIA
>
>Greg McGregor
>System Admin/DBA
>gregm@kew.starway.net.au
>~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
--
Octav Chiriac Phone: (373) 2 21 20 96
NetInfo S.R.L. Fax: (373) 2 21 36 59
Chisinau (373) 2 24 00 83
Moldova, Republic of mailto:com@netinfo-moldova.com