Re: IDS 9.3 Fatal Error
Posted in 2003
Rajib, thanks for the thoughts. The OS patches are up to date on the
system. A watcher program isn't a bad idea, even with resolving the
issue.
We did call Tech Support and got no help on the initial call, with an
"It shouldn't happen after IDS 7.3" answer. However, after seeing the
same Fatal Error the next day, we called Tech Support again and found
that there was a conflict between 2 different versions of Informix
Connect, versions 2.31 and 2.82, which were both installed on the
user's machine. After removing version 2.31 from the system the
connection problem seems to have disappeared.
We still don't have any specific data to indicate exactly what
happened to cause the system to crash, but I assume it was some sort
of compatibility issue between the old driver and IDS. The TSR
indicated that he hadn't used version 2.31 with any IDS 9.X servers at
all. So, as I've seen so many times in here before, it seems to be an
upgrade issue (or lack of it) that helped cause this.
Rajib Sarkar <rsarkar@us.ibm.com> wrote in message news:<bjnihd$4g1$1@terabinaries.xmission.com>...
> Looks like a SEGV happened on the ADM VP .... Have you checked whether all
> the OS patches are installed on the box ?? I would suggest opening up a
> case with Tech Support and they might be able to help ... In these kind of
> situations when there is no af file generated, I would suggest you to write
> some program to keep watching for a SEGV signal and then dumping the
> process stack using the pstack utility ..in fact you can pause() the
> process which received the signal and then take your dumps and then send a
> SIGTERM to the process ....
>
> Not much of an help ..just an idea though.
>
> Thanx much,
>
> Rajib Sarkar
> Advisory Software Engineer (RAS)
> IBM Data Management Group
> Ph : (602)-217-2100
> Fax: (602)-217-2100
> T/L : 667-2100
>
> As long as you derive inner help and comfort from anything, keep it --
> Mahatma Gandhi
>
>
>
> andrusg@intelihea
> lth.com (Gary To: informix-list@iiug.org
> Andrus) cc:
> Sent by: Subject: IDS 9.3 Fatal Error
> owner-informix-li
> st@iiug.org
>
>
> 09/09/2003 02:49
> PM
> Please respond to
> andrusg
>
>
>
>
>
> Platform : SunOS 5.7 sun4u sparc SUNW,Ultra-4
> IDS Version : 9.30.UC2
>
> We received the following error messages in our log file:
>
> 16:42:58 Fatal error in ADM VP at mt.c:11890
> 16:42:58 Unexpected virtual processor termination, pid = 1316, exit => 0xb
>
> Afterwards we were in a seriously degraded mode (15+ seconds for
> "onstat -"). Attempts to capture any additional information failed.
> So we tried to shutdown the server via onmode -ky. This command never
> completed. System shutdown also failed to complete, so we had to
> perform a halt.
>
> Has anyone seen this error before?
>
> During our investigation we found that we had a user attempting to
> connect via ODBC connection from ERwin 4.0 at nearly the same time as
> the fatal error. However, rather than an "olsoctcp" protocol,
> "onsoctcp" was selected. Could this have been the cause for the fatal
> error?
>
> TIA.
>
>
> sending to informix-list