Can't drop table or databse because of unsupported
Posted in 2014
Topics: Installation, Setup & Upgrades, Migration, Import/Export & Data Conversion, Platform-Specific Issues
Hello,
We are migrating from Ifx 11.50UC9 to 12.10FC2, i.e we change from 32 to 64
bit. The machine is Sun Sparc running Solaris.
We have a search engine that is implemented as an index method in a datablade,
like BTS. As part of the migration to 12.10 we will substitute the old search
engine with a new, the old one does not support 64 bit.
We obviously made a wrong decision to first migrate Informix then drop all
index and after that uninstall the index method/datablade. As the binaries
that are part of the datablade cannot load in the 64 bit Informix dropping an
index, a table with an index or the entire database does not work.
When we try to drop the index we get
216: Cannot remove index.
12802: Error in initializing an access_method routine execution sequence.
Trying to drop the table says
214: Cannot remove file for table (informix.tsokperson).
12802: Error in initializing an access_method routine execution sequence.
and trying to drop the database gives
214: Cannot remove file for table (informix.XXX).
12802: Error in initializing an access_method routine execution sequence.
If you look in the Informix log you get a message telling you
18:39:25 (62): The C Language Module <$INFORMIXDIR/extend/XXX/XXX.bld> can't
load
reason: ld.so.1: oninit: fatal: /opt/informix/121/extend/XXX/XXX.bld: wrong
ELF class: ELFCLASS32
As we have the *data* backed up the best solution is probably to just drop the
database and recreate it without the search engine parts.
Does anyone have a good idea how to handle this?
Best regards,
Rolf Wasteson
Knowit
Stockholm, Sweden
t +46-(0)-708 38 40 56
You have three options. 1) Revert back to v11.50, drop the database, then
upgrade again. 2) Export all of the data that doesn't depend on the search
module, create a new clean instance, and recreate the database(s) cleanly
under v12.10. 3) Open a support case with IBM and they should be able to
go into the server and manually remove the offending indexes.
Personally, I'm a fan of #2.
Art
Art S. Kagel, Principal Consultant
ASK Database Management
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on the IIUG, nor any other organization with which I am
associated either explicitly, implicitly, or by inference. Neither do
those opinions reflect those of other individuals affiliated with any
entity with which I am affiliated nor those of the entities themselves.
On Tue, Feb 11, 2014 at 1:03 PM, Rolf Wasteson <Rolf.Wasteson@knowit.se>wrote:
> Hello,
>
> We are migrating from Ifx 11.50UC9 to 12.10FC2, i.e we change from 32 to 64
> bit. The machine is Sun Sparc running Solaris.
>
> We have a search engine that is implemented as an index method in a
> datablade,
> like BTS. As part of the migration to 12.10 we will substitute the old
> search
> engine with a new, the old one does not support 64 bit.
>
> We obviously made a wrong decision to first migrate Informix then drop all
> index and after that uninstall the index method/datablade. As the binaries
> that are part of the datablade cannot load in the 64 bit Informix dropping
> an
> index, a table with an index or the entire database does not work.
>
> When we try to drop the index we get
>
> 216: Cannot remove index.
> 12802: Error in initializing an access_method routine execution sequence.>
> Trying to drop the table says
>
> 214: Cannot remove file for table (informix.tsokperson).
> 12802: Error in initializing an access_method routine execution sequence.>
> and trying to drop the database gives
>
> 214: Cannot remove file for table (informix.XXX).
> 12802: Error in initializing an access_method routine execution sequence.>
> If you look in the Informix log you get a message telling you
>
> 18:39:25 (62): The C Language Module <$INFORMIXDIR/extend/XXX/XXX.bld>
> can't
> load
>
> reason: ld.so.1: oninit: fatal: /opt/informix/121/extend/XXX/XXX.bld: wrong
> ELF class: ELFCLASS32
>
> As we have the *data* backed up the best solution is probably to just drop
> the
> database and recreate it without the search engine parts.
>
> Does anyone have a good idea how to handle this?
>
> Best regards,
>
> Rolf Wasteson
>
> Knowit
>
> Stockholm, Sweden
>
> t +46-(0)-708 38 40 56
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--047d7b3431ea4d16a904f225a8b5