error at onbar backup
Posted in 2009
Topics: Backup & Restore, Storage & Space Management, Error Codes & Troubleshooting
Hello
I will appreciate advice and tips about the following error:
2009-07-05 13:22:31 28221 28219 SQL -243 Could not position
within a table (informix.syschktab).
2009-07-05 13:22:31 28221 28219 ISAM -105 ISAM error: bad isam
file format.
at the
onbar -b -L 0 dbspacetime
Thanks in advance and best regards
--Néstor
It means that there may be disk corruption. Run:
oncheck -cdi sysmaster:informix.syschktab
To check on that. Also make sure that you are not executing an older
version of onbar!
Art
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Sun, Jul 5, 2009 at 2:38 PM, nestor gomez munoz
<nestorgm@prodigy.net.mx>wrote:
> Hello
> I will appreciate advice and tips about the following error:
>
> 2009-07-05 13:22:31 28221 28219 SQL -243 Could not position
> within a table (informix.syschktab).
> 2009-07-05 13:22:31 28221 28219 ISAM -105 ISAM error: bad isam
> file format.
>
> at the
> onbar -b -L 0 dbspace> time
>
> Thanks in advance and best regards
>
> --Néstor
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5b84dcc382b046dfd88c1
Thanks for your answer, Art, but it couldn't be onchecked:
oncheck -cdi sysmaster:informix.syschktabThis operation is not permitted on an SMI pseudo table
Is there any way to recreate that table?
--Nestor
El dom, 05-07-2009 a las 19:13 -0400, Art Kagel escribió:
> It means that there may be disk corruption. Run:
>
> oncheck -cdi sysmaster:informix.syschktab>
> To check on that. Also make sure that you are not executing an older
> version of onbar!
>
> Art
>
> Art S. Kagel
> Oninit (www.oninit.com)
> IIUG Board of Directors (art@iiug.org)
>
> Disclaimer: Please keep in mind that my own opinions are my own opinions and
> do not reflect on my employer, Oninit, the IIUG, nor any other organization
> with which I am associated either explicitly or implicitly. Neither do
> those opinions reflect those of other individuals affiliated with any entity
> with which I am affiliated nor those of the entities themselves.
>
> On Sun, Jul 5, 2009 at 2:38 PM, nestor gomez munoz
> <nestorgm@prodigy.net.mx>wrote:
>
> > Hello
> > I will appreciate advice and tips about the following error:
> >
> > 2009-07-05 13:22:31 28221 28219 SQL -243 Could not position
> > within a table (informix.syschktab).
> > 2009-07-05 13:22:31 28221 28219 ISAM -105 ISAM error: bad isam
> > file format.
> >
> > at the
> > onbar -b -L 0 dbspace> > time
> >
> > Thanks in advance and best regards
> >
> > --Nstor
> >
> >
> >
> >
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
> >
>
> --001636c5b84dcc382b046dfd88c1
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
You can recreate the pseudo table, but actually, I forgot that this was one
such. These pseudo tables are checked by other onchecks. Specifically run:
oncheck -cr # Check reserved pages.
oncheck -cDI # Check all tables and indexes including index keys.
You can rebuild the pseudo table itself by running the script
$INFORMIXDIR/etc/buildsmi
That should not be necessary unless this is a new instance or one upgraded
from a previous version. The sysmaster database is built or rebuilt in
these cases, but sometimes that build fails and you didn't notice. Also, if
you recently upgraded your IDS version, make sure that the onbar that you
are executing is not the older version. Check your path, run onbar -V to
get its version information, and try 'where onbar' to see if it is the
current one in $INFORMIXDIR. A common problem after an upgrade is to forget
to reset the current window's PATH by rerunning .profile or logging out and
back in or even to forget to adjust the global PATH settings in /etc/profile
or .profile if it was hard coded originally.
Art S. Kagel
Oninit (www.oninit.com)
IIUG Board of Directors (art@iiug.org)
Disclaimer: Please keep in mind that my own opinions are my own opinions and
do not reflect on my employer, Oninit, the IIUG, nor any other organization
with which I am associated either explicitly or implicitly. Neither do
those opinions reflect those of other individuals affiliated with any entity
with which I am affiliated nor those of the entities themselves.
On Mon, Jul 6, 2009 at 2:42 AM, nestor gomez munoz
<nestorgm@prodigy.net.mx>wrote:
> Thanks for your answer, Art, but it couldn't be onchecked:
>
> oncheck -cdi sysmaster:informix.syschktab> This operation is not permitted on an SMI pseudo table
>
> Is there any way to recreate that table?
>
> --Nestor
>
> El dom, 05-07-2009 a las 19:13 -0400, Art Kagel escribió:
> > It means that there may be disk corruption. Run:
> >
> > oncheck -cdi sysmaster:informix.syschktab> >
> > To check on that. Also make sure that you are not executing an older
> > version of onbar!
> >
> > Art
> >
> > Art S. Kagel
> > Oninit (www.oninit.com)
> > IIUG Board of Directors (art@iiug.org)
> >
> > Disclaimer: Please keep in mind that my own opinions are my own opinions
> and
> > do not reflect on my employer, Oninit, the IIUG, nor any other
> organization
> > with which I am associated either explicitly or implicitly. Neither do
> > those opinions reflect those of other individuals affiliated with any
> entity
> > with which I am affiliated nor those of the entities themselves.
> >
> > On Sun, Jul 5, 2009 at 2:38 PM, nestor gomez munoz
> > <nestorgm@prodigy.net.mx>wrote:
> >
> > > Hello
> > > I will appreciate advice and tips about the following error:
> > >
> > > 2009-07-05 13:22:31 28221 28219 SQL -243 Could not position
> > > within a table (informix.syschktab).
> > > 2009-07-05 13:22:31 28221 28219 ISAM -105 ISAM error: bad isam
> > > file format.
> > >
> > > at the
> > > onbar -b -L 0 dbspace> > > time
> > >
> > > Thanks in advance and best regards
> > >
> > > --Nstor
> > >
> > >
> > >
> > >
> >
>
>
*******************************************************************************
> > > Forum Note: Use "Reply" to post a response in the discussion forum.
> > >
> > >
> >
> > --001636c5b84dcc382b046dfd88c1
> >
> >
> >
>
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--001636c5a82f269b7f046e09caf1
Problem solved.
Definitely thanks very much, Art. I ran oncheck -cr sysmaster and it
took me to the source of error. Owner had changed on two chunks, posibly
after a support service on hardware and sysop.
Best regards.
--Nestor
El lun, 06-07-2009 a las 09:50 -0400, Art Kagel escribió:
> You can recreate the pseudo table, but actually, I forgot that this was one
> such. These pseudo tables are checked by other onchecks. Specifically run:
>
> oncheck -cr # Check reserved pages.
> oncheck -cDI # Check all tables and indexes including index keys.>
> You can rebuild the pseudo table itself by running the script
> $INFORMIXDIR/etc/buildsmi
>
> That should not be necessary unless this is a new instance or one upgraded
> from a previous version. The sysmaster database is built or rebuilt in
> these cases, but sometimes that build fails and you didn't notice. Also, if
> you recently upgraded your IDS version, make sure that the onbar that you
> are executing is not the older version. Check your path, run onbar -V to
> get its version information, and try 'where onbar' to see if it is the
> current one in $INFORMIXDIR. A common problem after an upgrade is to forget
> to reset the current window's PATH by rerunning .profile or logging out and
> back in or even to forget to adjust the global PATH settings in /etc/profile
> or .profile if it was hard coded originally.
>
> Art S. Kagel
> Oninit (www.oninit.com)
> IIUG Board of Directors (art@iiug.org)
>
> Disclaimer: Please keep in mind that my own opinions are my own opinions and
> do not reflect on my employer, Oninit, the IIUG, nor any other organization
> with which I am associated either explicitly or implicitly. Neither do
> those opinions reflect those of other individuals affiliated with any entity
> with which I am affiliated nor those of the entities themselves.
>
> On Mon, Jul 6, 2009 at 2:42 AM, nestor gomez munoz
> <nestorgm@prodigy.net.mx>wrote:
>
> > Thanks for your answer, Art, but it couldn't be onchecked:
> >
> > oncheck -cdi sysmaster:informix.syschktab> > This operation is not permitted on an SMI pseudo table
> >
> > Is there any way to recreate that table?
> >
> > --Nestor
> >
> > El dom, 05-07-2009 a las 19:13 -0400, Art Kagel escribi:
> > > It means that there may be disk corruption. Run:
> > >
> > > oncheck -cdi sysmaster:informix.syschktab> > >
> > > To check on that. Also make sure that you are not executing an older
> > > version of onbar!
> > >
> > > Art
> > >
> > > Art S. Kagel
> > > Oninit (www.oninit.com)
> > > IIUG Board of Directors (art@iiug.org)
> > >
> > > Disclaimer: Please keep in mind that my own opinions are my own opinions
> > and
> > > do not reflect on my employer, Oninit, the IIUG, nor any other
> > organization
> > > with which I am associated either explicitly or implicitly. Neither do
> > > those opinions reflect those of other individuals affiliated with any
> > entity
> > > with which I am affiliated nor those of the entities themselves.
> > >
> > > On Sun, Jul 5, 2009 at 2:38 PM, nestor gomez munoz
> > > <nestorgm@prodigy.net.mx>wrote:
> > >
> > > > Hello
> > > > I will appreciate advice and tips about the following error:
> > > >
> > > > 2009-07-05 13:22:31 28221 28219 SQL -243 Could not position
> > > > within a table (informix.syschktab).
> > > > 2009-07-05 13:22:31 28221 28219 ISAM -105 ISAM error: bad isam
> > > > file format.
> > > >
> > > > at the
> > > > onbar -b -L 0 dbspace> > > > time
> > > >
> > > > Thanks in advance and best regards
> > > >
> > > > --Nstor
> > > >
> > > >
> > > >
> > > >
> > >
> >
> >
>
*******************************************************************************
> > > > Forum Note: Use "Reply" to post a response in the discussion forum.
> > > >
> > > >
> > >
> > > --001636c5b84dcc382b046dfd88c1
> > >
> > >
> > >
> >
> >
>
*******************************************************************************
> > > Forum Note: Use "Reply" to post a response in the discussion forum.
> > >
> >
> >
> >
> >
>
*******************************************************************************
> > Forum Note: Use "Reply" to post a response in the discussion forum.
> >
> >
>
> --001636c5a82f269b7f046e09caf1
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>