SQL Error -1829
Posted in 2006
A multithreaded ESQL/C program was failing with SQL -1829 ("Cannot open file citoxmsg.pam"). Art Kagel's first guess was the usual cause: missing CSDK/Informix Connect or an unset/incorrect INFORMIXDIR (common in cron jobs). The actual cause here was the Unix per-process open-file limit being hit: the app spawns a thread per input file and apparently doesn't close files properly, so the message file couldn't be opened. Raising the limit from 1024 to 3072 fixed it; others noted similar cases needing much higher NOFILES values.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Error Codes & Troubleshooting
Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br
Usually this means that either you are trying to run an ESQL/C program on a client that does not have either the CSDK or Informix Connect installed or that the INFORMIXDIR environment variable is not properly set to the install directory of one of those products. Most commonly this happens to someone trying to run an ESQL/C program from a cron job script that's not setting the environment up. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 8:39:35 Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Art Kagel, I've already found out the problem, another member of iiug who is my friend sent me an e-mail explaining about the number of opened files on unix environment and this solved the problem. thank you any way. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 10:10 Para: ids@iiug.org Assunto: Re: SQL Error -1829 [7135] Usually this means that either you are trying to run an ESQL/C program on a client that does not have either the CSDK or Informix Connect installed or that the INFORMIXDIR environment variable is not properly set to the install directory of one of those products. Most commonly this happens to someone trying to run an ESQL/C program from a cron job script that's not setting the environment up. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 8:39:35 Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
Have to remember that one. We don't see it much any more. In the old days most UNIXes set the per user max open files to 16 or 32. Then we saw this problem frequently since IDS has many files it must open as do the clients. These days most set it to 1024 or more so the problem is rare. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 9:36:26 Art Kagel, I've already found out the problem, another member of iiug who is my friend sent me an e-mail explaining about the number of opened files on unix environment and this solved the problem. thank you any way. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 10:10 Para: ids@iiug.org Assunto: Re: SQL Error -1829 [7135] Usually this means that either you are trying to run an ESQL/C program on a client that does not have either the CSDK or Informix Connect installed or that the INFORMIXDIR environment variable is not properly set to the install directory of one of those products. Most commonly this happens to someone trying to run an ESQL/C program from a cron job script that's not setting the environment up. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 8:39:35 Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
It's rare at 1024.... We just set the NOFILES parameter to 10000 as per Informix tech support last night. It was set at 2000 and then we increased it to 4000 last month. Hopefully this will solve our issues. Wayne -----Original Message----- From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of ART KAGEL, .... Sent: Thursday, July 20, 2006 10:20 AM To: ids@iiug.org Subject: Re: RES: SQL Error -1829 [7137] Have to remember that one. We don't see it much any more. In the old days most UNIXes set the per user max open files to 16 or 32. Then we saw this problem frequently since IDS has many files it must open as do the clients. These days most set it to 1024 or more so the problem is rare. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 9:36:26 Art Kagel, I've already found out the problem, another member of iiug who is my friend sent me an e-mail explaining about the number of opened files on unix environment and this solved the problem. thank you any way. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 10:10 Para: ids@iiug.org Assunto: Re: SQL Error -1829 [7135] Usually this means that either you are trying to run an ESQL/C program on a client that does not have either the CSDK or Informix Connect installed or that the INFORMIXDIR environment variable is not properly set to the install directory of one of those products. Most commonly this happens to someone trying to run an ESQL/C program from a cron job script that's not setting the environment up. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 8:39:35 Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br **************************************************************************** *** Forum Note: Use "Reply" to post a response in the discussion forum. **************************************************************************** *** Forum Note: Use "Reply" to post a response in the discussion forum. **************************************************************************** *** Forum Note: Use "Reply" to post a response in the discussion forum. **************************************************************************** *** Forum Note: Use "Reply" to post a response in the discussion forum. Please do not transmit orders or instructions regarding a UBS account by e-mail. The information provided in this e-mail or any attachments is not an official transaction confirmation or account statement. For your protection, do not include account numbers, Social Security numbers, credit card numbers, passwords or other non-public information in your e-mail. Because the information contained in this message may be privileged, confidential, proprietary or otherwise protected from disclosure, please notify us immediately by replying to this message and deleting it from your computer if you have received this communication in error. Thank you. UBS Financial Services Inc. UBS International Inc.
Art Kagel, it was really set to 1024 and I changed to 3072 to fix, the program is multithread and depends on the number of input file to open that threads (it opens one thread for each input file), and i think the programer is not closing the file corectly. Thanks Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 11:20 Para: ids@iiug.org Assunto: Re: RES: SQL Error -1829 [7137] Have to remember that one. We don't see it much any more. In the old days most UNIXes set the per user max open files to 16 or 32. Then we saw this problem frequently since IDS has many files it must open as do the clients. These days most set it to 1024 or more so the problem is rare. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 9:36:26 Art Kagel, I've already found out the problem, another member of iiug who is my friend sent me an e-mail explaining about the number of opened files on unix environment and this solved the problem. thank you any way. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 10:10 Para: ids@iiug.org Assunto: Re: SQL Error -1829 [7135] Usually this means that either you are trying to run an ESQL/C program on a client that does not have either the CSDK or Informix Connect installed or that the INFORMIXDIR environment variable is not properly set to the install directory of one of those products. Most commonly this happens to someone trying to run an ESQL/C program from a cron job script that's not setting the environment up. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 8:39:35 Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.
SOunds like it. LIke it said, at 1024 it's a rare problem. It really takes a badly written app to run into that high an open file limit. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 10:47:33 Art Kagel, it was really set to 1024 and I changed to 3072 to fix, the program is multithread and depends on the number of input file to open that threads (it opens one thread for each input file), and i think the programer is not closing the file corectly. Thanks Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 11:20 Para: ids@iiug.org Assunto: Re: RES: SQL Error -1829 [7137] Have to remember that one. We don't see it much any more. In the old days most UNIXes set the per user max open files to 16 or 32. Then we saw this problem frequently since IDS has many files it must open as do the clients. These days most set it to 1024 or more so the problem is rare. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 9:36:26 Art Kagel, I've already found out the problem, another member of iiug who is my friend sent me an e-mail explaining about the number of opened files on unix environment and this solved the problem. thank you any way. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br -----Mensagem original----- De: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org]Em nome de ART KAGEL, .... Enviada em: quinta-feira, 20 de julho de 2006 10:10 Para: ids@iiug.org Assunto: Re: SQL Error -1829 [7135] Usually this means that either you are trying to run an ESQL/C program on a client that does not have either the CSDK or Informix Connect installed or that the INFORMIXDIR environment variable is not properly set to the install directory of one of those products. Most commonly this happens to someone trying to run an ESQL/C program from a cron job script that's not setting the environment up. Art S. Kagel ----- Original Message ----- From: Celso Cabra.... <ids@iiug.org> At: 7/20 8:39:35 Hello, I'm receiving the sql error -1829, in a program C using threading, somebody knows what does it mean? SQLSTATE: IX001 SQLCODE: -1829 ISAM: 0 -1829 Cannot open file citoxmsg.pam. The file citoxmsg.pam is missing from the directory $INFORMIXDIR/msg. If this error occurs, note all circumstances and contact Technical Support at tsmail@us.ibm.com. Celso Coimbra ClearTech Ltda "Unlock your revenue" NOVO Tel: (019) 2104-4509 E-mail: ccoimbra@cleartech.com.br ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum. ******************************************************************************* Forum Note: Use "Reply" to post a response in the discussion forum.