dbaccess fails on windows Unknown error message 79
Posted in 2012
A user running IDS 11.50 Developer Edition on Windows 7 found that dbaccess wouldn't start, failing with "Unknown error message 79514", while oninit, oncheck and onstat worked fine. The poster answered his own question: setting INFORMIXDIR alone isn't enough — the Windows PATH must also include %INFORMIXDIR%\\bin (e.g. C:\\PROGRA~1\\IBM\\IBMINF~1\\11.50\\bin); without it you just get that unhelpful message. The rest of the thread drifts into debate about Informix on Windows vs Unix/Linux, missing tools (onmonitor, onperf, 64-bit OAT), and using snapshot backups with 'onmode -c block'.
Auto-generated by DrWatson from the posts below — may be imperfect; read the full thread.
Topics: Server Administration, Versions, Editions & End-of-Life
IBM Informix Dynamic Server Version 11.50.FC9DE Software Serial Number
AAA#B000000
windows V 6.1 Build 7601 service pack1
dbaccess on windows fails to start with error message
Unknown error message 79514.
oninit oncheck and onstat work ok
does anyone have ideas why it wont work please
You are running on Windows? Half serious now, but, why not just give up
and reformat the main drive with Linux and run Informix that way. It will
be WAY more stable and perform better to boot.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Wed, Aug 22, 2012 at 9:20 PM, KARL OLIVER <karl.oliver@maf.govt.nz>wrote:
> IBM Informix Dynamic Server Version 11.50.FC9DE Software Serial Number
> AAA#B000000
> windows V 6.1 Build 7601 service pack1
>
> dbaccess on windows fails to start with error message
> Unknown error message 79514.
> oninit oncheck and onstat work ok
>
> does anyone have ideas why it wont work please
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--14dae9340af302e28b04c7e4be6b
Art Would love to Unfortunately managemnent want to trial it on windows. In fact eventually they want to migrate all our informix stuff on unix to sequal server.Going to informix on windows is an intermideiate step they are thinking of. Yes we have advised against running informix on windows. There is all the code to change as well of course. We are just trialing as you have worked out hence no support. We might have to buy some for our trial ! We do have support for our production system of course.
> You are running on Windows? Half serious now, but, why not just give up and reformat the main drive with Linux and run Informix that way. It will be WAY more stable and perform better to boot. > Art, are you implying that the 11.70 Windows version does not receive adequate support attention as the *NIX versions? There are many requirements out there for the Win version and it should be fixed for reliable functionality!
Hmm, I might be talking out of my kippah, but I thought that trials and
demos include support during the trial period. Wouldn't do to have some
Informix Newbie decide the product is NG because he can't spell oninit.
;-) Give IBM a call.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Wed, Aug 22, 2012 at 9:35 PM, KARL OLIVER <karl.oliver@maf.govt.nz>wrote:
> Art
> Would love to
> Unfortunately managemnent want to trial it on windows.
> In fact eventually they want to migrate all our informix stuff on unix to
> sequal server.Going to informix on windows is an intermideiate step they
> are
> thinking of.
> Yes we have advised against running informix on windows. There is all the
> code
> to change as well of course.
> We are just trialing as you have worked out hence no support. We might
> have to
> buy some for our trial !
>
> We do have support for our production system of course.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--14dae9340c3b824d1e04c7e5470e
First, I do not consider Windows an enterprise level operating system on which I would want to bet my business. I have worked on UNIX systems that have been online with no downtime since before windows existed. As for Informix on Windows, I only know that there are more REALLY weird goings on with Informix on Windows than on Linux or Unix. My laptop for example. About once a year or so I decide that I need a copy of Informix Innovator-C (or before that DE) running natively (I have several copies on there in Linux VMs that have been available for me to run for years and they all still start up smoothly) on the laptop to make demos easier. So I install the latest and greatest, create an instance, and use it for a month or two. Shutdowns and start ups work fine and the engine is accessible for a while. Then one day, the engine is still online but it won't let me connect to it at all. Rebooting, restarting the services manually, running starts, etc. all result in a running instance that I can't talk to. Reinstalling is the only solution and so I give up for another 10 months or so... Right now I'm in give-it-up mode and mood. IBM's fault? My fault? HP's fault (laptop is a Pavilion)? MS's fault? Dunno, don't care. IDS is running downstairs on my Ubuntu box for over 7 years now. Upgraded periodically. Moved from DE to IC. It just always works (though for about 2 weeks of the year I can't connect to it with any windows apps <sigh> running on my laptop (then windows connectivity magically starts working again - OK, not fair, I tracked that down finally to my router's DHCP mucking with the addresses). Anyway, do you catch a pattern there somewhere? Art Art S. Kagel Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Wed, Aug 22, 2012 at 9:56 PM, FRANK J. COMPUTER <frank_in_pr@hotmail.com>wrote: > > > You are running on Windows? Half serious now, but, why not just give up > and reformat the main drive with Linux and run Informix that way. It will > be WAY more stable and perform better to boot. > > > > Art, are you implying that the 11.70 Windows version does not receive > adequate > support attention as the *NIX versions? There are many requirements out > there > for the Win version and it should be fixed for reliable functionality! > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --14dae9340af38e066204c7e57193
so far my expereince with informix on windows
no onmonitor
no onperf
oninit -i does not workno OAT to run on windows 64 bit
Had an onconfig error that was not even written to the log on start up when it
failed.
I know onperf and onmonitor tools are old but I find them effective.In fact i
find onperf graphic excellent way of monitoring performance
We are currently running 24 x 7 enterprise replication on HP since this is so
reliable i can sleep at night.
Will informix running on windows provide me the same luxury ?
Not impressed so far with informix on windows.
When windows servers perform badly and no one knows why - the old reboot of
server is done at this site!
well the answer
needed this path
set PATH=C:\\\\PROGRA~1\\\\IBM\\\\IBMINF~1\\\\11.50\\\\bin
I thought things would have worked just by having INFORMIXDIR set at
C:\\\\PROGRA~1\\\\IBM\\\\IBMINF~1\\\\11.50
apprently not you just get the useless message previously noted
There are issues. Windows is a poor cousin, a port from Unix and things =
don't work as well, or as you'd always expect. I would always choose =
Unix over Windows for an Informix deployment. In a recent test we got =
10x improvement by moving our database to CentOS.
I was pleasantly surprised with an easy HDR setup under Windows, =
although we have not deployed one to the field, so I am unfamiliar with =
a lot of details there.
Otherwise, we have several hundred (I don't know the exact number, I =
don't think we're into the thousands, but I could be wrong) deployments =
of Windows/IDS without DBAs and I get support calls pretty infrequently =
- 4-6/year? Typically pibkac.
j.
On Aug 22, 2012, at 11:15 PM, KARL OLIVER wrote:
> so far my expereince with informix on windows=20
> no onmonitor=20
> no onperf=20
> oninit -i does not work=20> no OAT to run on windows 64 bit=20
> Had an onconfig error that was not even written to the log on start up =
when it=20
> failed.=20
> I know onperf and onmonitor tools are old but I find them effective.In =
fact i=20
> find onperf graphic excellent way of monitoring performance=20
> We are currently running 24 x 7 enterprise replication on HP since =
this is so=20
> reliable i can sleep at night.=20
> Will informix running on windows provide me the same luxury ?=20
>=20
> Not impressed so far with informix on windows.=20
> When windows servers perform badly and no one knows why - the old =
reboot of=20
> server is done at this site!=20
>=20
>=20
> =
**************************************************************************=
*****=20
> Forum Note: Use "Reply" to post a response in the discussion forum.=20=
>=20
Since this thread has drifted into the merits of windows and ids here is my two bob bit... I've been using the Windows version of IDS for 14 years or so I guess (I think ids 7.3 was first server version, had the networked DOS version before that). Anyway, once it is set up and running properly it has been very stable, although the initial installs on new servers always seem to have "issues". The only other problem is the monthly security updates to windows that often require the servers to be rebooted to apply them. On the plus side for windows is snapshot backups of the entire system (based on windows volume shadow service - e.g. ShadowProtect, Acronis,..etc). On hardware failure this has got us out of the 'creek' very quickly - can restore entire system in short time frame on any bare metal (or if none available can run up the server in a virtual machine direct from the backup image - big performance hit of course but gets it running). However, if there was a snapshot backup product for Linux that was as straight forward to use I'd consider changing over to Linux for the performance boost. At the moment the powers that be won't look at linux due to not knowing of a good easy-to-use backup/restore product that can capture point-in-time stable images of the entire system, including hourly incrementals, and most importantly restore them nicely. If you know of product please let me know :-) Regards, Bryce Stenberg.
Don't know about automated system snapshots of the entire system, but the
Informix archive and logical log backups and restores using either ontape
or onbar with a system archive package such as Tivoli, Netbackup, etc.
works very well.
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Thu, Aug 23, 2012 at 1:16 AM, BRYCE STENBERG <bryce@hrnz.co.nz> wrote:
> Since this thread has drifted into the merits of windows and ids here is my
> two bob bit...
>
> I've been using the Windows version of IDS for 14 years or so I guess (I
> think
> ids 7.3 was first server version, had the networked DOS version before
> that).
>
> Anyway, once it is set up and running properly it has been very stable,
> although the initial installs on new servers always seem to have "issues".
> The
> only other problem is the monthly security updates to windows that often
> require the servers to be rebooted to apply them.
>
> On the plus side for windows is snapshot backups of the entire system
> (based
> on windows volume shadow service - e.g. ShadowProtect, Acronis,..etc). On
> hardware failure this has got us out of the 'creek' very quickly - can
> restore
> entire system in short time frame on any bare metal (or if none available
> can
> run up the server in a virtual machine direct from the backup image - big
> performance hit of course but gets it running).
>
> However, if there was a snapshot backup product for Linux that was as
> straight
> forward to use I'd consider changing over to Linux for the performance
> boost.
> At the moment the powers that be won't look at linux due to not knowing of
> a
> good easy-to-use backup/restore product that can capture point-in-time
> stable
> images of the entire system, including hourly incrementals, and most
> importantly restore them nicely. If you know of product please let me know
> :-)
>
> Regards, Bryce Stenberg.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--14dae93409032757e204c7e8165d
While there is no native 64 bit port to run on a Windows 64 bit operating
system,
you can run a 32 bit version of OAT on a Windows 64 bit operating system.
So
the line about no OAT support for windows 64 bit is a little over stated.
> no OAT to run on windows 64 bit
John F. Miller III
STSM, Embedability Architect
miller3@us.ibm.com
503-578-5645
IBM Informix Dynamic Server (IDS)
ids-bounces@iiug.org wrote on 08/22/2012 08:15:35 PM:
> From: "KARL OLIVER" <karl.oliver@maf.govt.nz>
> To: ids@iiug.org
> Date: 08/22/2012 08:16 PM
> Subject: Re: dbaccess fails on windows Unknown error messag [28132]
> Sent by: ids-bounces@iiug.org
>
> so far my expereince with informix on windows
> no onmonitor
> no onperf
> oninit -i does not work> no OAT to run on windows 64 bit
> Had an onconfig error that was not even written to the log on start
> up when it
> failed.
> I know onperf and onmonitor tools are old but I find them effective.In
fact i
> find onperf graphic excellent way of monitoring performance
> We are currently running 24 x 7 enterprise replication on HP since this
is so
> reliable i can sleep at night.
> Will informix running on windows provide me the same luxury ?
>
> Not impressed so far with informix on windows.
> When windows servers perform badly and no one knows why - the old reboot
of
> server is done at this site!
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
EMCs BCP process is fairly impressive. =20 I'm interested that you're using the Windows snapshot backups, I've seen = third party backup solutions crap out the database, including the = Microsoft and Symantec products. But with respect to the DB, yes very stable on Windows. j. On Aug 23, 2012, at 1:16 AM, BRYCE STENBERG wrote: > Since this thread has drifted into the merits of windows and ids here = is my=20 > two bob bit...=20 >=20 > I've been using the Windows version of IDS for 14 years or so I guess = (I think=20 > ids 7.3 was first server version, had the networked DOS version before = that).=20 >=20 > Anyway, once it is set up and running properly it has been very = stable,=20 > although the initial installs on new servers always seem to have = "issues". The=20 > only other problem is the monthly security updates to windows that = often=20 > require the servers to be rebooted to apply them.=20 >=20 > On the plus side for windows is snapshot backups of the entire system = (based=20 > on windows volume shadow service - e.g. ShadowProtect, Acronis,..etc). = On=20 > hardware failure this has got us out of the 'creek' very quickly - can = restore=20 > entire system in short time frame on any bare metal (or if none = available can=20 > run up the server in a virtual machine direct from the backup image - = big=20 > performance hit of course but gets it running).=20 >=20 > However, if there was a snapshot backup product for Linux that was as = straight=20 > forward to use I'd consider changing over to Linux for the performance = boost.=20 > At the moment the powers that be won't look at linux due to not = knowing of a=20 > good easy-to-use backup/restore product that can capture point-in-time = stable=20 > images of the entire system, including hourly incrementals, and most=20= > importantly restore them nicely. If you know of product please let me = know :-)=20 >=20 > Regards, Bryce Stenberg.=20 >=20 >=20 > = **************************************************************************= *****=20 > Forum Note: Use "Reply" to post a response in the discussion forum.=20= >=20
On Wed, Aug 22, 2012 at 8:15 PM, KARL OLIVER <karl.oliver@maf.govt.nz>wrote: > so far my experience with Informix on Windows > no onmonitor > Get used to no ON-Monitor; it is not part of the next major release of Informix on Unix, either. -- Jonathan Leffler <jonathan.leffler@gmail.com> #include <disclaimer.h> Guardian of DBD::Informix - v2011.0612 - http://dbi.perl.org "Blessed are we who can laugh at ourselves, for we shall never cease to be amused." --e89a8f2353bb64db5404c7f06523
-you can run a 32 bit version of OAT on a Windows 64 bit operating system. So well I could not get it to work - so gave up
we wont be going to a next version of informix it will all be sequel server - unfortunately
>-----Original Message-----
>From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Jack
Parker
>
>I'm interested that you're using the Windows snapshot backups, I've seen
third party backup solutions crap out the database, including the Microsoft
and Symantec products.
We use StorageCraft ShadowProtect (had a lot of pain years ago with symantec
product so ditched it).
We have done restores a number of times for various reasons like hardware
failure, bringing virtual copy of server up in a testing environment,
upgrading to new hardware..
Anyway, we've never encountered an error or corruption in the process. We just
make sure we do 'onmode -c block' before snapshot and 'onmode -c unblock'
immediately after the snapshot so we get a consistent database state for the
backup (snapshot typically takes between 5 and 15 seconds to complete so our
users don't seem to notice). Also every time a log is backed up we copy
current ixbar.0 file to snapshot location so we can easily roll the logs
forward after recovery for the hour that may have been missed since last
incremental snapshot.
However, I have limited experience in that we are using growth edition and
don't use replication, etc. YMMV.
Regards, Bryce Stenberg.
Interesting, both customers were unaware of the block operation. Since =
we offer them an ontape backup, we just tell them not to use third party =
solutions, something to think about.
j.
On Aug 23, 2012, at 5:39 PM, BRYCE STENBERG wrote:
>> -----Original Message-----=20
>> From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of =
Jack=20
> Parker=20
>>=20
>> I'm interested that you're using the Windows snapshot backups, I've =
seen=20
> third party backup solutions crap out the database, including the =
Microsoft=20
> and Symantec products.=20
>=20
> We use StorageCraft ShadowProtect (had a lot of pain years ago with =
symantec=20
> product so ditched it).=20
>=20
> We have done restores a number of times for various reasons like =
hardware=20
> failure, bringing virtual copy of server up in a testing environment,=20=
> upgrading to new hardware..=20
>=20
> Anyway, we've never encountered an error or corruption in the process. =
We just=20
> make sure we do 'onmode -c block' before snapshot and 'onmode -c =
unblock'=20
> immediately after the snapshot so we get a consistent database state =
for the=20
> backup (snapshot typically takes between 5 and 15 seconds to complete =
so our=20
> users don't seem to notice). Also every time a log is backed up we =
copy=20
> current ixbar.0 file to snapshot location so we can easily roll the =
logs=20
> forward after recovery for the hour that may have been missed since =
last=20
> incremental snapshot.=20
>=20
> However, I have limited experience in that we are using growth edition =
and=20
> don't use replication, etc. YMMV.=20
>=20
> Regards, Bryce Stenberg.=20
>=20
>=20
> =
**************************************************************************=
*****=20
> Forum Note: Use "Reply" to post a response in the discussion forum.=20=
>=20
Art, I've experienced the same symptoms you described with my install of 11.70.TC5 (x86/32-bit). As to your feelings, and comments of other users on this thread, all I have to say is, If IBM will not release a stable Win version and properly maintain it, then they should withdraw from offering it on Win platforms, although neglecting Windows is big strategic mistake!.. It's still a necessary evil and has a useful place.