Is bug 157690 the problem that is referenced in IBM technical document 1174689?
Posted in 2004
Topics: Backup & Restore, Storage & Space Management, Transactions, Locking & Isolation
Hello All,
I was on IBM's technical support search site
("http://www-1.ibm.com/support/us/search/index.html") reading tech doc
1174689 (below) and remarked out loud to my west highland terrier of
how it looked similar to a problem one of my customers had. They were
told by Informix support that they encountered bug 157690. Tech doc
1174689 doesn't refer to any bugs, but does anyone know if it is
157690? If it's not 157690, is it another bug? If a bug, what versions
is it fixed in? Whatever happened to that product defect query! Any
help is appreciated; Thanks in advance.
Brice Avila
-------------------
XBSA error 148 (0x94) during onbar backup
Technote (FAQ)
Problem
On-Bar backup fails with return code 148 (0x94)
Solution
PROBLEM
ON-Bar fails during an archive and you receive an XBSA error 148
(0x94) in the bar_act log with an error message similar to one of
following:
Prior to version 9.3:
2004-07-16 17:42:21 20591 20589 /usr/921FC6/bin/onbar_d -b -L 0
2004-07-16 17:43:21 20591 20589 SQL 4294967040 Transaction not
available.
2004-07-16 17:43:56 20591 20589 /usr/921FC6/bin/onbar_d complete,
returning 148 (0x94)
Version 9.3 and above:
2004-07-20 11:15:38 19835 19833 /usr/940UC3/bin/onbar_d -b -L 0
2004-07-20 11:15:40 19835 19833 Begin level 0 backup rootdbs.
2004-07-20 11:15:41 19835 19833 Successfully connected toStorage
Manager.
2004-07-20 11:16:08 19835 19833 SQL -568 Cannot reference an
external database without logging.
2004-07-20 11:16:19 19835 19833 SQL -568 Cannot reference an
external database without logging.
2004-07-20 11:16:19 19835 19833 /usr/940UC3/bin/onbar_d complete,
returning 148 (0x94)
CAUSE
The sysutils database is not allowing transaction logging.
SOLUTION
You can use one of following options:
* Change the logging status of the existing sysutils
* Change the sysutils database logging mode to "unbuffered logging".
You can use ontape or ondblog utility to change the logging mode.
* Rebuild the sysutils database
* Run '$INFORMIXDIR/etc/buildsmi' script to recreate the sysutils
database.
Check documents in the Related Information section for more
information.
Reference #: 1174689
Bug: 157690 WHEN RUNNING ONSMSYNC WILL GET ERROR THAT WHOLE_BACKUP IS
NOT IN ANY TABLE IN THE QUERY AND IT WILL CLEAN OUT ALL OF THE IXBAR
FILE
doesn't look like the same problem
can't find any bug that matches the advice below. what is described
below doesn't sound like a bug. sounds like someone turned off logging
on sysutils and this gives you some ways of turning it back on
personally I think the short description below is a little weak as
almost any error returned by the database generates error XBSA 148
briceavila@hotmail.com (Brice Avila) wrote in message news:<c46e3ec5.0410120551.64c2adda@posting.google.com>...
> Hello All,
>
> I was on IBM's technical support search site
> ("http://www-1.ibm.com/support/us/search/index.html") reading tech doc
> 1174689 (below) and remarked out loud to my west highland terrier of
> how it looked similar to a problem one of my customers had. They were
> told by Informix support that they encountered bug 157690. Tech doc
> 1174689 doesn't refer to any bugs, but does anyone know if it is
> 157690? If it's not 157690, is it another bug? If a bug, what versions
> is it fixed in? Whatever happened to that product defect query! Any
> help is appreciated; Thanks in advance.
>
> Brice Avila
>
> -------------------
>
> XBSA error 148 (0x94) during onbar backup
>
> Technote (FAQ)
>
> Problem
> On-Bar backup fails with return code 148 (0x94)
>
> Solution
>
> PROBLEM
>
> ON-Bar fails during an archive and you receive an XBSA error 148
> (0x94) in the bar_act log with an error message similar to one of
> following:
>
>
> Prior to version 9.3:
>
> 2004-07-16 17:42:21 20591 20589 /usr/921FC6/bin/onbar_d -b -L 0
> 2004-07-16 17:43:21 20591 20589 SQL 4294967040 Transaction not
> available.
> 2004-07-16 17:43:56 20591 20589 /usr/921FC6/bin/onbar_d complete,
> returning 148 (0x94)
>
> Version 9.3 and above:
>
> 2004-07-20 11:15:38 19835 19833 /usr/940UC3/bin/onbar_d -b -L 0
> 2004-07-20 11:15:40 19835 19833 Begin level 0 backup rootdbs.
> 2004-07-20 11:15:41 19835 19833 Successfully connected toStorage
> Manager.
> 2004-07-20 11:16:08 19835 19833 SQL -568 Cannot reference an
> external database without logging.
> 2004-07-20 11:16:19 19835 19833 SQL -568 Cannot reference an
> external database without logging.
> 2004-07-20 11:16:19 19835 19833 /usr/940UC3/bin/onbar_d complete,
> returning 148 (0x94)
>
> CAUSE
>
> The sysutils database is not allowing transaction logging.
>
> SOLUTION
>
> You can use one of following options:
>
> * Change the logging status of the existing sysutils
> * Change the sysutils database logging mode to "unbuffered logging".
> You can use ontape or ondblog utility to change the logging mode.
> * Rebuild the sysutils database
> * Run ?$INFORMIXDIR/etc/buildsmi' script to recreate the sysutils
> database.
>
> Check documents in the Related Information section for more
> information.
>
> Reference #: 1174689