Re: Question on Disk errors
Posted in 2012
Laurie:
see below:
Art
Art S. Kagel
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Fri, Nov 2, 2012 at 1:17 PM, Laurie Gustin <lgustin@utah.gov> wrote:
> Has anyone seen these type of disk errors with IDS?? this is a new server
> and it would be great to get things set up as best we can from the
> beginning.
>
> Any feedback is appreciated :)
>
> We have IDS11.70
> Direct IO = 1
>
> The error I'm seeing is
>
> EXT4-fs (dm-13): Unaligned AIO/DIO on inode 34 by oninit; performance will
> be poor.
>
The filesystem's pagesize isn't compatible with Informix's AIO requests.
>
> Questions to ask.
>
> 1. Can we change informix to avoid this error or problems?
>
You need to modify the filesystem.
> 2. If nothing is done will it cause corruption of the database or file
> system?
>
No, just reduced performance.
> 3. Are we better off moving to a different file system like EXT3 or EXT2.
>
EXT4 should NEVER be used for any data about which you care. LInus
Torvalds said that EXT4 was ".... designed by morons. No ifs ands or buts
about it." Its write-back feature which cannot be disabled, writes
metadata changes before the data that they map which can cause
unrecoverable corruption if the filesystem crashes before the data gets
written. Both EXT3 and EXT4 are bad for databases. They share the same
copy-on-write logging scheme which causes the server's chunks to become
more and more fragmented over time reducing performance drastically. It is
best to use EXT2 for database chunks on Linux if you cannot or don't want
to use RAW devices.
> 4. Could this be caused by the volume being a LVM should we not use LVM's
> and just use non LVM partitions.
>
LVMs are OK.
> 5. Can we change how the volume is mounted to avoid this error or problems?
>
>
>
> _______________________________________________
> Informix-list mailing list
> Informix-list@iiug.org
> http://www.iiug.org/mailman/listinfo/informix-list
>
>