Re: Cannot Add Index (-212) & (-105)
Posted in 2008
On Mar 3, 4:59 am, sdhaya <dhaya.sni...@gmail.com> wrote:
> Hi Tilman,
>
> I have part of the af.781131c file..
> In the first line of the file I can see the following :-
>
> 17:13:49 bfcheck: bad page: pg_addr 0:-1056899072 != bp->bf_pagenum
> 152:476>
> Further down I see
>
> chunk info
> chunk info
> 00000002a033fb88: fffffff2 00980000 0016e360
> 00000000 ........ ...`....
> 00000002a033fb98: 0016e0ba 00000000 00000000
> 00000019 ........ ........
> 00000002a033fba8: 00010040 08000098 001b2f64 65762f69 ...@.... ../
> dev/i
> 00000002a033fbb8: 6e666f72 6d69782f 74656d70 64627330 nformix/
> tempdbs0
> 00000002a033fbc8: 312e6430 31000000 00000000 00000000
> 1.d01... ........
> 00000002a033fbd8: 00000000 00000000 00000000
> 00000000 ........ ........
> 00000002a033fbe8: 00000000 00000000 00000000
> 00000000 ........ ........
> 00000002a033fbf8: 00000000 00000000 00000000
> 00000000 ........ ........
> 00000002a033fc08: 00000000 00000000 00000000
> 00000000 ........ ........
>
> The error in the table it failed 'prime20:"ymulla".tpaymentalloc' is a
> temporary table which gets created while running our EOM process.
>
> The "/dev/informix/tempdbs01.d01" is our temporary DBSpace in the
> database. Can we create a new temporary DBSpace and remove the
> "tempdbs01" in the DBSPACETEMP variable and use the new DBSPACE.. Say
> "tempdbs04"..... Will this help to narrow down the issue.
>
> DBSPACETEMP tempdbs01,tempdbs02,tempdbs03 # Default temp dbspaces
>
> On Mar 2, 8:02 pm, tilleu...@web.de wrote:
>
> > > 17:13:49 Assert Failed: Page Check Error in next_scan:bad data page
> > > 17:13:49 IBM Informix Dynamic Server Version 10.00.FC5
> > > 17:13:49 Who: Session(669, ymulla@prime2_endofday.cbq.com.qa, 1256,
> > > 29f571a68)
> > > Thread(921, xchg_3.0, 29f53d7c0, 1)
> > > File: rsdebug.c Line: 1056
> > > 17:13:49 Results: Possible inconsistencies in> > > 'prime20:"ymulla".tpaymentalloc'
> > > 17:13:49 Action: Run 'oncheck -cD 159383595'
> > > 17:13:49 stack trace for pid 2856 written to /export/home/informix/
> > > tmp/af.781131c
> > > 17:13:49 See Also: /export/home/informix/tmp/af.781131c
> > > 17:13:54 Page Check Error in next_scan:bad data page
> > > 17:19:07 Fuzzy Checkpoint Completed: duration was 22 seconds, 12112> > > buffers not flushed.
>
> > Dahya,
> > As Norma already suggested - this does not seem to be a temp space
> > issue. Rather looks like corruption on disk.
> > It might be interesting to have a look at the file af.781131c , the
> > contents of the bad page should be in there.
> > If the page is indeed corrupted you would have to find out whether
> > corruption is limited to the one page or more widespread. (Use oncheck
> > as suggested , if possible while no users are on the system). Then -
> > most important - try find out what's wrong and remove the cause. You
> > might want to ask IBM Informix Tech Support for help.
> > Rgds
> > Tilman
I believe this could be a known issue. When using temporary dbspaces
and temp tables, when a light scan occurs (like would likely happen if
you are trying to create in index on your temp table), the light scan
can read a page from disk when it's actually been modified in shared
memory (so the scan pulls a bad page not like what it's expecting from
disk), but hasn't been flushed out yet (as modified buffers in
dbspaces that are marked as temp are either not flushed at
checkpoints, or delay flushing, don't recall off the top of my head).
If I recall this problem was fixed in 10.00.xC6.
Jacques