URGENT: chunk failure at installation
Posted in 1999
Topics: Installation, Setup & Upgrades, Storage & Space Management, Server Administration, Networking & sqlhosts Configuration
Sun SPARC 7 box, IFX 7.31 UC2a . I completed all the steps as per the release notes, created a raw device on one of 9gig disk at partition 4. I get following error message, pl help Oninit:Cannot open chunk '/usr/informix/chunk1' errno = 2 Oninit:Fatal error in shared memory initialization. I have updated /etc/system file, /etc/sqlhosts file and changed onconfig file to include correct base memory address (SHMBASE parameter). Any hints ? TIA Mukund
Shevkar - I've been through this a number of times, but am too busy to address it now. Please email on Monday if still not solved. The most important things to check are permissions on the symbolic links to your informix raw data files, and the user/group names assigned to those links. The "Cannot open" is really true - for some ordinary Unix file system reason, the devices are not openable. Here are some of our links on Solaris ... check for consistency? Rich lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw02 -> /devices/pci@1f,4000/scsi@3/sd@9,0:e,raw lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw03 -> /devices/pci@1f,4000/scsi@3/sd@9,0:f,raw lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw04 -> /devices/pci@1f,4000/scsi@3/sd@9,0:g,raw lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw05 -> /devices/pci@1f,4000/scsi@3/sd@9,0:h,raw lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw06 -> /devices/pci@1f,4000/scsi@3/sd@a,0:d,raw lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw07 -> /devices/pci@1f,4000/scsi@3/sd@a,0:e,raw lrwxrwxrwx 1 informix informix 40 Mar 3 14:06 ifmxraw08 -> /devices/pci@1f,4000/scsi@3/sd@a,0:f,raw "Shevkar, Mukund" wrote: > Sun SPARC 7 box, IFX 7.31 UC2a . > > I completed all the steps as per the release notes, created a raw device on > one of 9gig disk > at partition 4. I get following error message, pl help > > Oninit:Cannot open chunk '/usr/informix/chunk1' errno = 2 > Oninit:Fatal error in shared memory initialization. > > I have updated /etc/system file, /etc/sqlhosts file and changed onconfig > file > to include correct base memory address (SHMBASE parameter). > > Any hints ? > > TIA > > Mukund -- Richard C. Auslander Database Manager AirFlash, Inc. 1733 Woodside Rd., Suite #110 Redwood City, CA 94061 (650) 556-7928 www.airflash.com
Some basic items to check: 1. Make sure the raw device has the proper ownership (informix/informix) and permissions (660). 2. Make sure chunk size + offset is less than 2 GB. 3. I would not prefer to have chunks (or even links to it) in the /usr filesystem (this may or may not be related to your problem...). 4. Check the informix log file for more info - you may have an explanation of the problem in there. Hal Maner Shevkar, Mukund wrote in message <7pki9d$9tb$1@news.xmission.com>... > >Sun SPARC 7 box, IFX 7.31 UC2a . > >I completed all the steps as per the release notes, created a raw device on >one of 9gig disk >at partition 4. I get following error message, pl help > >Oninit:Cannot open chunk '/usr/informix/chunk1' errno = 2 >Oninit:Fatal error in shared memory initialization. > >I have updated /etc/system file, /etc/sqlhosts file and changed onconfig >file >to include correct base memory address (SHMBASE parameter). > >Any hints ? > >TIA > >Mukund
Thanks, Hal - I neglected to add that you should examine the Informix system log file ./etc/online.log -- it should have a major clue in it. Hal Maner wrote: > Some basic items to check: > > 1. Make sure the raw device has the proper ownership (informix/informix) > and permissions (660). > > 2. Make sure chunk size + offset is less than 2 GB. > > 3. I would not prefer to have chunks (or even links to it) in the /usr > filesystem (this may or may not be related to your problem...). > > 4. Check the informix log file for more info - you may have an explanation > of the problem in there. > > Hal Maner > > Shevkar, Mukund wrote in message <7pki9d$9tb$1@news.xmission.com>... > > > >Sun SPARC 7 box, IFX 7.31 UC2a . > > > >I completed all the steps as per the release notes, created a raw device on > >one of 9gig disk > >at partition 4. I get following error message, pl help > > > >Oninit:Cannot open chunk '/usr/informix/chunk1' errno = 2 > >Oninit:Fatal error in shared memory initialization. > > > >I have updated /etc/system file, /etc/sqlhosts file and changed onconfig > >file > >to include correct base memory address (SHMBASE parameter). > > > >Any hints ? > > > >TIA > > > >Mukund -- Richard C. Auslander Database Manager AirFlash, Inc. 1733 Woodside Rd., Suite #110 Redwood City, CA 94061 (650) 556-7928 www.airflash.com