Re: log_full.sh script exits with code 139
Posted in 1997
Hitesh Dave wrote:
>
> Hi Everybody,
>
> We are running sun solaris 5.5.1 with Informix 7.23.
>
> I am seeing following messagaes in my online.log file.
>
> 11:26:25 Checkpoint Completed: duration was 1 seconds.
> 11:27:15 Logical Log 1701 Complete.
> 11:27:18 Process exited with return code 139: /bin/sh /bin/sh -c> /usr/informix/etc/log_full.sh 2 23 "Logical Log 1701 Complete." "Logical
> Log 1701 Complete."
> 11:27:19 Logical Log 1701 - Backup Started
> 11:27:42 Logical Log 1701 - Backup Completed
> 11:29:27 Checkpoint Completed: duration was 2 seconds.>
> I do not follow what "process exited with return code 139 means and
> what implications it can have on our log files.
Your ALARMPROGRAM is returning a non-zero exit code. The alarm program,
in your case the script /usr/informix/etc/log_full.sh, is executed for
any of several interesting events in the engine one of which is when a
logical log file completes. Your config file specifies the sample log
full event handler script the Informix puts into the onconfig.std as an
example. That script is probably failing or at least returning a code
that looks to the engine like an error condition.
Null out the ALARMPROGRAM, enter your own script or executable, or fix
the log_full.sh script.
Art S. Kagel