Changing data structure forced command termination.
Posted in 1998
Huh?
Hi Family.
One of my users just upgraded their engine to ODS-7.24.UC3 from
7.13.UC5. Of course, no upgrade is without some grief. Here is a
manifestation of the grief we get now:
I ran onstat -u and got some lines of output - all the daemons and the
first bunch of users in the sessions list. Suddenly the output ends,
way before it should, with the message:
Changing data structure forced command termination.
I tried onstat -g ses and got exactly one line of output before getting
the same message.
THIS IS NUTS!! If the data structure has changed, the onstat code was
surely changed to match it. If the code was not sufficiently changed, it
would not have gotten a single line out the door; it would probably have
dumped core.
I don't know what other commands will be terminated with this error
message. So far, onstat -g ppf, ath, act (besides the ses) have all
ended with this error message. I don't need to try every possible
option before realizing there is a more global problem here.
The app seems to running fine without recompilation (OK, some termcap
problems seem to be cropping up.)
Anyone got a clue?
Thanks.
--
-- Jake (Pondering the color of an asphyxiated smurf)
+------------------------------------------------------------+
| The expedient performance of a task with excessive concern |
| regarding its duration-to-completion engenders a virtual |
| certainty of diminished benefit therefrom. |
| -- Benjamin Franklin (but he said it in 3 words) |
+------------------------------------------------------------+