Getting 23705 error in XPS
Posted in 2013
Topics: Storage & Space Management, Stored Procedures & SPL, Server Administration, Migration, Import/Export & Data Conversion, Platform-Specific Issues
We are running Informix 8.21.UD2X2 XPS on AIX 4.3.3.0. We are trying to look
at data in the tables, but on certain tables we are getting the following
error message:
23705: Could not open file: (cosvr, file, errno)=(1,/<tablename>.unload,13)
The finder indicates that the server couldn't open a file. Could this mean
that there isn't enough disk space to get the data on this table? The errno 13
indicates that permission is denied, but the directory is owned by Informix
and is able to be written to from what I can see.
Has anyone else seen this before? I know that this is old, but we are running
out of space on this server and need to do more analysis for what data can be
unloaded and deleted.
Keith Schleicher
IT Database Administrator
Cell: 224-210-8358
Blackberry:
2242108358@messaging.sprintpcs.com<mailto:2242108358@messaging.sprintpcs.com>
Page: 2242108358@sprint.skytel.com<mailto:2242108358@sprint.skytel.com>
For more information, use our DBA Wiki page link below:
http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat
abaseManagement<http://wiki.intra.sears.com/confluence/display/TechStrag/Databas
e+Management>
This message, including any attachments, is the property of Sears Holdings
Corporation and/or one of its subsidiaries. It is confidential and may contain
proprietary or legally privileged information. If you are not the intended
recipient, please delete it without reading the contents. Thank you.
That table is probably an external table which is just a pointer into a
flat file on disk (ie /tablename.unload) and it may be that someone deleted
the file at some point but more likely given the errno, the privileges on
the file are incorrect. Check the permissions on the file using ls -l and
fix them. It should be owned by user informix and group informix and have
0660 permissions.
Art
Art S. Kagel, Principal Consultant
Advanced DataTools (www.advancedatatools.com)
Blog: http://informix-myview.blogspot.com/
Disclaimer: Please keep in mind that my own opinions are my own opinions
and do not reflect on my employer, Advanced DataTools, the IIUG, nor any
other organization with which I am associated either explicitly,
implicitly, or by inference. Neither do those opinions reflect those of
other individuals affiliated with any entity with which I am affiliated nor
those of the entities themselves.
On Fri, Nov 1, 2013 at 11:57 AM, Schleicher, Keith <
Keith.Schleicher@searshc.com> wrote:
> We are running Informix 8.21.UD2X2 XPS on AIX 4.3.3.0. We are trying to
> look
> at data in the tables, but on certain tables we are getting the following
> error message:
>
> 23705: Could not open file: (cosvr, file, errno)=(1,/<tablename>.unload,13)>
> The finder indicates that the server couldn't open a file. Could this mean
> that there isn't enough disk space to get the data on this table? The
> errno 13
> indicates that permission is denied, but the directory is owned by Informix
> and is able to be written to from what I can see.
>
> Has anyone else seen this before? I know that this is old, but we are
> running
> out of space on this server and need to do more analysis for what data can
> be
> unloaded and deleted.
>
> Keith Schleicher
> IT Database Administrator
> Cell: 224-210-8358
> Blackberry:
> 2242108358@messaging.sprintpcs.com<mailto:
> 2242108358@messaging.sprintpcs.com>
> Page: 2242108358@sprint.skytel.com<mailto:2242108358@sprint.skytel.com>
>
> For more information, use our DBA Wiki page link below:
>
>
>
http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management#Dat
abaseManagement
> <
> http://wiki.intra.sears.com/confluence/display/TechStrag/Database+Management
> >
>
> This message, including any attachments, is the property of Sears Holdings
> Corporation and/or one of its subsidiaries. It is confidential and may
> contain
> proprietary or legally privileged information. If you are not the intended
> recipient, please delete it without reading the contents. Thank you.
>
>
>
>
*******************************************************************************
> Forum Note: Use "Reply" to post a response in the discussion forum.
>
>
--089e0158c0048ca7ab04ea209895