Re: Micro$oft SQL Server 2005 (64 bit version) to IDS 9.40 Linkedserver
Posted in 2008
Hi Jared, I was hoping that the latest CSDK release of the Windows 64bit port would have addressed this long standing issue but I doesn't so here's what you need to do in order to setup a linked server under SQL Server. This is for version 3.50.FC2. You may want to backup your registry before doing this. Copy the section below to a file with a '.reg' extension like CSDK-FIX.reg and then double click the file to load the data into your registry. Once you done that I recommend that you reboot, although you should be able to get away with simply restarting SQL Server and restarting the Distributed Transaction Coordinator service. That's it! Now you should be able to create a linked server as you would for a 32bit instance. Take note that this registry information is only for the CSDK 3.50.FC2, if you instead have IConnect installed or some other version of the CSDK, the registry keys are different but similar. You'll need to open up regedit, search under 'HKEY_CLASSES_ROOT\\Wow6432Node\\CLSID' for the string 'ifxole' search under 'HKEY_LOCAL_MACHINE\\SOFTWARE\\Wow6432Node\\Microsoft\\MSDTC\\XADLL' for the string 'IfmxConn.dll' and 'iclit09b.dll'. Unload all those keys to a file, edit the file and remove 'Wow6432Node' and load the new keys into the registry. Jim --copy-from-here-- Windows Registry Editor Version 5.00 [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}] @="Ifxoledbc" "OLEDB_SERVICES"=dword:ffffffff [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}\\ExtendedErrors] @="IfxoledbcErrorLookup" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}\\ExtendedErrors\\{A6D00423-FD6C-11D0-8043-00A0C90F1C59}] @="Informix OLE DB Error Lookup Service" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}\\InprocServer32] @="C:\\\\Program Files (x86)\\\\IBM\\\\Informix\\\\Client-SDK\\\\bin\\\\ifxoledbc.dll" "InprocServer32"=hex(7):63,00,6f,00,54,00,32,00,5e,00,2c,00,50,00,24,00,49,00,\\ 3f,00,63,00,74,00,74,00,43,00,64,00,33,00,7a,00,4d,00,45,00,28,00,4f,00,6c,\\ 00,65,00,44,00,62,00,3e,00,6c,00,39,00,32,00,27,00,2b,00,5a,00,5e,00,25,00,\\ 67,00,28,00,60,00,5f,00,39,00,65,00,66,00,7b,00,7a,00,56,00,2b,00,36,00,00,\\ 00,00,00 "ThreadingModel"="Both" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}\\OLE DB Provider] @="IBM Informix OLE DB Provider" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}\\ProgID] @="Ifxoledbc.2" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00422-FD6C-11D0-8043-00A0C90F1C59}\\VersionIndependentProgID] @="Ifxoledbc" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00423-FD6C-11D0-8043-00A0C90F1C59}] @="IfxoledbcErrorLookup" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00423-FD6C-11D0-8043-00A0C90F1C59}\\InprocServer32] @="C:\\\\Program Files (x86)\\\\IBM\\\\Informix\\\\Client-SDK\\\\bin\\\\ifxoledbc.dll" "InprocServer32"=hex(7):63,00,6f,00,54,00,32,00,5e,00,2c,00,50,00,24,00,49,00,\\ 3f,00,63,00,74,00,74,00,43,00,64,00,33,00,7a,00,4d,00,45,00,28,00,4f,00,6c,\\ 00,65,00,44,00,62,00,3e,00,6c,00,39,00,32,00,27,00,2b,00,5a,00,5e,00,25,00,\\ 67,00,28,00,60,00,5f,00,39,00,65,00,66,00,7b,00,7a,00,56,00,2b,00,36,00,00,\\ 00,00,00 "ThreadingModel"="Both" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00423-FD6C-11D0-8043-00A0C90F1C59}\\ProgID] @="IfxoledbcErrorLookup.2" [HKEY_CLASSES_ROOT\\CLSID\\{A6D00423-FD6C-11D0-8043-00A0C90F1C59}\\VersionIndependentProgID] @="IfxoledbcErrorLookup" [HKEY_LOCAL_MACHINE\\SOFTWARE\\Microsoft\\MSDTC\\XADLL] "iclit09b.dll"="C:\\\\Program Files (x86)\\\\IBM\\\\Informix\\\\Client-SDK\\\\bin\\\\iclit09b.dll" "IfmxConn.dll"="C:\\\\Program Files (x86)\\\\IBM\\\\Informix\\\\Client-SDK\\\\bin\\\\IfmxConn.dll" --copy-to-here-- On Mon, Oct 13, 2008 at 2:49 PM, <jared.hanks@gmail.com> wrote: > Hey Jim. > > I saw this on the Google groups. I'm having a problem with setting up > an ODBC connection to Informix 9.40 database from SQL Server 2005 64- > bit instance. It looks like you found a way to get it to work?? Can > you please share? > > Thanks, > Jared > > > ---------- Forwarded message ---------- > From: "Everett Mills" <eemills@nationalbeef.com> > Date: Mar 19, 9:36 am > Subject: Micro$oft SQL Server 2005 (64 bit version) to IDS 9.40 > Linkedserver > To: comp.databases.informix > > > I would like that as well. > > --EEM > > ________________________________ > > From: informix-list-bounces@iiug.org > [mailto:informix-list-bounces@iiug.org] On Behalf Of DL Redden > Sent: Wednesday, March 19, 2008 11:34 AM > To: Jim Tranny > Cc: Informix List > Subject: Re: Micro$oft SQL Server 2005 (64 bit version) to IDS 9.40 > Linkedserver > > Jim that would be fantastic. I had never thought about digging around > in > the registry to look for misplaced keys. Please do send me the files. > > ----- Original Message ---- > From: Jim Tranny <jimtranny@gmail.com> > To: DL Redden <redden96@yahoo.com> > > Cc: Informix-List (E-Mail) <informix-list@iiug.org> > Sent: Wednesday, March 19, 2008 11:16:05 AM > Subject: Re: Micro$oft SQL Server 2005 (64 bit version) to IDS 9.40 > Linked server > > DL, you're getting hit by the 64bit CSDK install bug. The Windows > 64bit CSDK does come with the 64 bit driver. I've reported the issue > to IBM during the open beta of the Windows 64bity port but I think > it's still present. > > The problem is with the installer and how it creates its registry > entries. It creates the entries under the Wow6432Node when it should > not. I can send you the files I wrote to correct this. > > Jim > > On Wed, Mar 19, 2008 at 12:03 PM, DL Redden <redden96@yahoo.com> > wrote: > >> We have not gotten linked servers to Informix to work with 64-bit > MSSQL. I >> believe the reason is that the OLEDB driver that comes with the 64-bit >> Informix client is still a 32-bit driver. Since MSSQL is 64-bit it > cannot >> utilize a 32-bit OLEDB driver. It's very frustrating and I've spent a >> considerable amount of time trying everything that I could think of or > find. >> I have not tried support, either IBM or Microsoft. > >> ----- Original Message ---- >> From: Everett Mills <eemills@nationalbeef.com> >> To: Informix-List (E-Mail) <informix-list@iiug.org> >> Sent: Wednesday, March 19, 2008 10:03:34 AM >> Subject: Micro$oft SQL Server 2005 (64 bit version) to IDS 9.40 Linked >> server > >> Guys- >> We have a new SQueaL Server 2005 64 bit install which need to >> read some data from our IDS 9.40.UC8 instances running on HP-UX 11.11. >> This has been no problem for grabbing data with the 32 bit version of >> SQueaL: create a DSN for the IDS instance and use ODBC for the linked >> server. The 64 bit SqueaL doesn't support ODBC, which has left us >> floundering. The server with SqueaL has CSDK 3.0.FC3 installed and > the >> IDS server has had the most recent version of coledbp.sql run on it. >> The IDS server has been set up in SetNet 32. >> Has anyone gotten