Re: Cannot set/unset DELIMIDENT
Posted in 2004
Topics: Server Administration
Jonathan Leffler <jleffler@earthlink.net> wrote in message news:<T98id.16121 > See my session G08 "Is Your DBA Paranoid Enough?" from the IBM DMTC > 2004. I fear your DBA (DBSA - Database System Administrator) isn't > paranoid enough. > Maybe he is; maybe he wants to enforce a policy of using SQL/92 compliant statements as much as possible. I purposefully set DELIMIDENT when starting a server because I want to make sure that my teammates aren't developing code that will fail if DELIMIDENT is set or if it ends up running against a DB2 or Orable server. -Chris
Plausible Indirection wrote: > Jonathan Leffler <jleffler@earthlink.net> wrote: >>See my session G08 "Is Your DBA Paranoid Enough?" from the IBM DMTC >>2004. I fear your DBA (DBSA - Database System Administrator) isn't >>paranoid enough. > > Maybe he is; maybe he wants to enforce a policy of using SQL/92 > compliant statements as much as possible. I purposefully set > DELIMIDENT when starting a server because I want to make sure that my > teammates aren't developing code that will fail if DELIMIDENT is set > or if it ends up running against a DB2 or Orable server. OK - that's fair enough as a conscious decision; I have done it occasionally myself (mainly to prove the point). As an unconscious decision, which seemed to the situation with the OP, it usually indicates an insufficiently paranoid DBSA. -- Jonathan Leffler #include <disclaimer.h> Email: jleffler@earthlink.net, jleffler@us.ibm.com Guardian of DBD::Informix v2003.04 -- http://dbi.perl.org/