Re: Error -406 all the time (SE7.1)
Posted in 1996
In <3286AB00.2906@msoft.alphanet.com.au> Pete McDonald <petem@msoft.alphanet.com.au> writes: >Anyone upgraded from RDS4.1/SE5.0 to RDS6.0/SE7.1?? >If the answer is yes, please help!!! Running under Sco Unix, our >existing database systems run without a problem. Problems start to >happen, however, when we try to re-compile and run them with RDS6.0 and >SE7.1. >We get no compile-time errors, but when we run them we either get a -406 >error (Memory allocation failed) or simply a core dump (at various >seemingly un-related points in the code). At the suggestion of Informix >AUS, we have bumped up our ULIMIT, but to no avail. We've even >re-created the databases with the new engine. >Are we being really stupid and missing something obvious, or is there >some magic trick we have to perform? >Thanks in advance. >Our company is having a problem transferring existing Informix 4gl-RDS >systems from RDS4.1/SE5.0 to RDS6.0/SE7.1. Gidday Pete I have recently completed the same excercise on the same operatinf system with the same release numbers of Informix RDS and SE. I found similar problems to your self, and heres a list; Random core dumps within the code : I found that RUN RETURNING xxxx caused the problem. Disabling these lines returned the code to normal operation (apart from the RUN :(). Informix AUS told me it was a bug and I am awaiting a patch release. Odd arithmetical errors : Turned out to be the 'float' variable type. Changing to decimal(X,Y) fixed the problems, Informix has no answer at this stage. Odd arethmetical errors 2 : RDS 6.x reports dont seem to default initialise declared variables in the report the way 4.x did. This means you've got to do iit yourself in FIRST PAGE HEADER, which makes for messy code if you already have a PAGE HEADER block. Informix investigating, no answer yet. INPUT ARRAY REQUIRED attribute : INPUT ARRAY on fields with REQUIRED set dont work WITHOUT DEFAULTS. The default value displays OK, but a simple <enter> to get out of the field returns "A value is required in this field". Overtyping just one character in the field satisfies it, and the whole default value is returned to the input variable in the correct fashion. Informix have called it a bug, and I await their patch with baited breath. RDS falls over with "myfuncfail - failed at 860 spipe.c". Dont know, cant fix it, Informix has been told of the problem. No answer at this stage. Also, read the release notes carefully ( as I'm sure you already have ), there are quite a lot of differences and fixes in the Toolset (much more in the engine of course, but I dont think this is causing your heartache). Good luck, please e-mail me if you have other questions, or you get any good news that might ease my own situation. SCO 5.0.2 SE 7.12.UC1 RDS 6.03.UC1 Bryan Tonnet batonnet@zeta.org.au