Re: 7 vs 9
Posted in 2004
--0__=09BBE5FEDFD617EF8f9e8a93df938690918c09BBE5FEDFD617EF Content-type: text/plain; charset=US-ASCII Content-transfer-encoding: quoted-printable rotor wrote: >>$EXECUTE IMMEDIATE "CREATE TEMP TABLE lvo ( id INT ) WITH NO LOG"; >>$EXECUTE IMMEDIATE "CREATE INDEX lvo ON lvo( id )"; >>This fragment works on 7.x without any problems. But on 9.x the last >>statement fails with sql error -242 (isam -106). Please response who >>knows why the difference exists and which server has bug. The default behavior of CREATE INDEX in IDS 9 is to create a detached i= ndex versus IDS 7 which creates an attached index. The attached index requi= res less space. I believe the SQL Syntax manual gives the algorithm for th= e calculation of the detached index initial extent size. Christine = --0__=09BBE5FEDFD617EF8f9e8a93df938690918c09BBE5FEDFD617EF Content-type: text/html; charset=US-ASCII Content-Disposition: inline Content-transfer-encoding: quoted-printable <html><body> <p>rotor wrote:<br> <br> <tt>>>$EXECUTE IMMEDIATE "CREATE TEMP TABLE lvo ( id INT ) W= ITH NO LOG";<br> >>$EXECUTE IMMEDIATE "CREATE INDEX lvo ON lvo( id )";<b= r> <br> >>This fragment works on 7.x without any problems. But on 9.x the= last <br> >>statement fails with sql error -242 (isam -106). Please respons= e who <br> >>knows why the difference exists and which server has bug.<br> </tt><br> <tt>The default behavior of CREATE INDEX in IDS 9 is to create a detach= ed index versus IDS 7 which creates an attached index. The attach= ed index requires less space. I believe the SQL Syntax manual giv= es the algorithm for the calculation of the detached index initial exte= nt size.</tt><br> <br> Christine <br> <br> </body></html>= --0__=09BBE5FEDFD617EF8f9e8a93df938690918c09BBE5FEDFD617EF-- sending to informix-list