aus_work_info
Posted in 2013
Topics: High Availability & Replication, Installation, Setup & Upgrades, Storage & Space Management, Stored Procedures & SPL, Server Administration, Security, Permissions & Auditing, Logging & Checkpoints, Platform-Specific Issues, Versions, Editions & End-of-Life
Folks, IDS11.50 FC8, Redhat Linux. A couple of days ago, we reverted IDS from 11.70 FC7 back to 11.50 FC8. Today we did a inplace upgrade of OS of Linux from Redhat Linux 5 to 6. When I started database, the error shows, SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 The specified table (aus_work_info) is not in the database. 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 ISAM Any comments? Thanks, Frank ==================== Attachd more log info, 15:52:04 IBM Informix Dynamic Server Started. 15:52:04 Segment locked: addr=0x44000000, size=2099167232 Wed Nov 20 15:52:06 2013 15:52:06 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has insecure permissions 15:52:06 Event alarms enabled. ALARMPROG = '/usr/informix/etc/alarmprogram.sh' 15:52:06 Booting Language <c> from module <> 15:52:06 Loading Module <CNULL> 15:52:06 Booting Language <builtin> from module <> 15:52:06 Loading Module <BUILTINNULL> 15:52:12 DR: DRAUTO is 0 (Off) 15:52:12 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled) 15:52:12 Event notification facility epoll enabled. 15:52:12 IBM Informix Dynamic Server Version 11.50.FC8 Software Serial Number AAA#B000000 15:52:14 IBM Informix Dynamic Server Initialized -- Shared Memory Initialized. 15:52:14 Started 1 B-tree scanners. 15:52:14 B-tree scanner threshold set at 5000. 15:52:14 B-tree scanner range scan size set to -1. 15:52:14 B-tree scanner ALICE mode set to 6. 15:52:14 B-tree scanner index compression level set to med. 15:52:14 Physical Recovery Started at Page (35:143858). 15:52:14 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored. 15:52:14 Logical Recovery Started. 15:52:14 10 recovery worker threads will be started. 15:52:15 Logical Recovery has reached the transaction cleanup phase. 15:52:15 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks 15:52:17 Dataskip is now OFF for all dbspaces 15:52:17 SCHAPI: Started dbScheduler thread. 15:52:17 requested number of KAIO events (10000) exceeds limit (7768). using 7768. 15:52:18 Booting Language <spl> from module <> 15:52:18 Loading Module <SPLNULL> 15:52:18 SCHAPI: Started 2 dbWorker threads. 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 The specified table (aus_work_info) is not in the database. 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 ISAM error: no record found. 15:52:18 Checkpoint Completed: duration was 1 seconds. 15:52:18 Wed Nov 20 - loguniq 540, logpos 0x12126018, timestamp: 0x7b063fd8 Interval: 61383 --001a11c3765ecec20b04eb9dfc93
It looks like the procedures in sysadmin that AUS uses were not reverted properly. Best to save any changes to the default task scheduling and any private tasks you've installed, drop sysadmin, and rebuild it using 11.50. Art Art S. Kagel, Principal Consultant Advanced DataTools (www.advancedatatools.com) Blog: http://informix-myview.blogspot.com/ Disclaimer: Please keep in mind that my own opinions are my own opinions and do not reflect on my employer, Advanced DataTools, the IIUG, nor any other organization with which I am associated either explicitly, implicitly, or by inference. Neither do those opinions reflect those of other individuals affiliated with any entity with which I am affiliated nor those of the entities themselves. On Wed, Nov 20, 2013 at 11:08 AM, FRANK <yunyaoqu@gmail.com> wrote: > Folks, > > IDS11.50 FC8, Redhat Linux. > > A couple of days ago, we reverted IDS from 11.70 FC7 back to 11.50 FC8. > Today we did a inplace upgrade of OS of Linux from Redhat Linux 5 to 6. > > When I started database, the error shows, > > SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 The specified > table (aus_work_info) is not in the database. > 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 ISAM > > Any comments? > > Thanks, > Frank > > ==================== > Attachd more log info, > > 15:52:04 IBM Informix Dynamic Server Started. > 15:52:04 Segment locked: addr=0x44000000, size=2099167232 > Wed Nov 20 15:52:06 2013 > 15:52:06 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has insecure > permissions > 15:52:06 Event alarms enabled. ALARMPROG = > '/usr/informix/etc/alarmprogram.sh' > 15:52:06 Booting Language <c> from module <> > 15:52:06 Loading Module <CNULL> > 15:52:06 Booting Language <builtin> from module <> > 15:52:06 Loading Module <BUILTINNULL> > 15:52:12 DR: DRAUTO is 0 (Off) > 15:52:12 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled) > 15:52:12 Event notification facility epoll enabled. > 15:52:12 IBM Informix Dynamic Server Version 11.50.FC8 Software Serial > Number AAA#B000000 > 15:52:14 IBM Informix Dynamic Server Initialized -- Shared Memory > Initialized. > 15:52:14 Started 1 B-tree scanners. > 15:52:14 B-tree scanner threshold set at 5000. > 15:52:14 B-tree scanner range scan size set to -1. > 15:52:14 B-tree scanner ALICE mode set to 6. > 15:52:14 B-tree scanner index compression level set to med. > 15:52:14 Physical Recovery Started at Page (35:143858). > 15:52:14 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored. > 15:52:14 Logical Recovery Started. > 15:52:14 10 recovery worker threads will be started. > 15:52:15 Logical Recovery has reached the transaction cleanup phase. > 15:52:15 Logical Recovery Complete. > > 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks > 15:52:17 Dataskip is now OFF for all dbspaces > 15:52:17 SCHAPI: Started dbScheduler thread. > 15:52:17 requested number of KAIO events (10000) exceeds limit (7768). > using 7768. > 15:52:18 Booting Language <spl> from module <> > 15:52:18 Loading Module <SPLNULL> > 15:52:18 SCHAPI: Started 2 dbWorker threads. > 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 The > specified table (aus_work_info) is not in the database. > 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 ISAM > error: no record found. > 15:52:18 Checkpoint Completed: duration was 1 seconds. > 15:52:18 Wed Nov 20 - loguniq 540, logpos 0x12126018, timestamp: > 0x7b063fd8 Interval: 61383 > > --001a11c3765ecec20b04eb9dfc93 > > > > ******************************************************************************* > Forum Note: Use "Reply" to post a response in the discussion forum. > > --089e0116136a14830104eb9e1e32
Original post:
Folks,
IDS11.50 FC8, Redhat Linux.
A couple of days ago, we reverted IDS from 11.70 FC7 back to 11.50 FC8.
Today we did a inplace upgrade of OS of Linux from Redhat Linux 5 to 6.
When I started database, the error shows,
SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 The specified
table (aus_work_info) is not in the database.
15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 ISAM
Any comments?
Thanks,
Frank
Response:
I believe the aus_work_info table is dropped and created every time the Auto
Update Statistics Evaluation task is run. Also, in the SPL where the table is
dropped, there is on exception blocks that would have the SPL ignore the 206error...so that would imply to me the error happened in some other place
during the task...and it seems to me the only way that would be possible is if
somehow perhaps the Auto Update Statistics Evaluation task was trying to be
run by 2 worker threads so the 2nd run dropped the table after the 1st run had
dropped/recreated the table and so then the 1st run got an error the table
didn't exist and then the 2nd run completed with no problems. I think you
could check to see if that happened by finding the tk_id of the Auto Update
Statistics Evaluation task (you can do select * from ph_task where tk_name
matches "Auto Update Statistics Evaluation") and then using the tk_id, do a
select * from ph_run where run_task_id = <the td_id from previousquery>...that will get you all the times that task was run and the run_time
column is when that task was run...so perhaps you'd find that task run at
either 2 identical times with different run_id's and run_task_seq numbers
(indicating different runs of that task) or run_time's within a couple
seconds/minutes of each over (not sure how far apart they could possibly
be...it would depend on your system and how long that task took to complete).
Generally speaking, I would say the error was likely harmless and it would
just mean the task failed at that particular time...as long as it doesn't
continually fail and ran successfully the next time around I'd guess you are
ok. But to get the 206 error when the task itself is dropping and creating the
aus_work_info table, I think either the task got started twice by 2 different
worker threads (or maybe the worker threads internally started up the task and
then somebody manually executed the task as well so that's how it got started
twice) and 1 stepped on the other, or somebody else would have had to drop the
aus_work_info table while the task was running.
Jacques Renaut
IBM Informix Advanced Support
APD Team
You are likely running into known defect which fixed in IDS 11.50.FC10.= Defect idsdb00238361 (APAR idsdb00238362) - Auto Update Statistic Refr= esh Evaluation fails with error -206 on table aus_work_info Please contact IBM Tech Support to get the fix for the problem. Regards, Nita Dembla, PMP=AE IBM Informix Development nita@us.ibm.com = "FRANK" = <yunyaoqu@gmail.c = om> = To Sent by: ids@iiug.org, = ids-bounces@iiug. = cc org = Subj= ect aus_work_info [31981] = 11/20/2013 11:08 = AM = = = Please respond to = ids@iiug.org = = = Folks, IDS11.50 FC8, Redhat Linux. A couple of days ago, we reverted IDS from 11.70 FC7 back to 11.50 FC8.= Today we did a inplace upgrade of OS of Linux from Redhat Linux 5 to 6.= When I started database, the error shows, SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 The specif= ied table (aus_work_info) is not in the database. 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 I= SAM Any comments? Thanks, Frank =3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D=3D Attachd more log info, 15:52:04 IBM Informix Dynamic Server Started. 15:52:04 Segment locked: addr=3D0x44000000, size=3D2099167232 Wed Nov 20 15:52:06 2013 15:52:06 Warning: ONCONFIG dump directory (DUMPDIR) '/tmp' has insecure= permissions 15:52:06 Event alarms enabled. ALARMPROG =3D '/usr/informix/etc/alarmprogram.sh' 15:52:06 Booting Language <c> from module <> 15:52:06 Loading Module <CNULL> 15:52:06 Booting Language <builtin> from module <> 15:52:06 Loading Module <BUILTINNULL> 15:52:12 DR: DRAUTO is 0 (Off) 15:52:12 DR: ENCRYPT_HDR is 0 (HDR encryption Disabled) 15:52:12 Event notification facility epoll enabled. 15:52:12 IBM Informix Dynamic Server Version 11.50.FC8 Software Serial Number AAA#B000000 15:52:14 IBM Informix Dynamic Server Initialized -- Shared Memory Initialized. 15:52:14 Started 1 B-tree scanners. 15:52:14 B-tree scanner threshold set at 5000. 15:52:14 B-tree scanner range scan size set to -1. 15:52:14 B-tree scanner ALICE mode set to 6. 15:52:14 B-tree scanner index compression level set to med. 15:52:14 Physical Recovery Started at Page (35:143858). 15:52:14 Physical Recovery Complete: 0 Pages Examined, 0 Pages Restored= . 15:52:14 Logical Recovery Started. 15:52:14 10 recovery worker threads will be started. 15:52:15 Logical Recovery has reached the transaction cleanup phase. 15:52:15 Logical Recovery Complete. 0 Committed, 0 Rolled Back, 0 Open, 0 Bad Locks 15:52:17 Dataskip is now OFF for all dbspaces 15:52:17 SCHAPI: Started dbScheduler thread. 15:52:17 requested number of KAIO events (10000) exceeds limit (7768). using 7768. 15:52:18 Booting Language <spl> from module <> 15:52:18 Loading Module <SPLNULL> 15:52:18 SCHAPI: Started 2 dbWorker threads. 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -206 T= he specified table (aus_work_info) is not in the database. 15:52:18 SCHAPI: [Auto Update Statistics Evaluation 38-14] Error -111 I= SAM error: no record found. 15:52:18 Checkpoint Completed: duration was 1 seconds. 15:52:18 Wed Nov 20 - loguniq 540, logpos 0x12126018, timestamp: 0x7b063fd8 Interval: 61383 --001a11c3765ecec20b04eb9dfc93 ***********************************************************************= ******** Forum Note: Use "Reply" to post a response in the discussion forum. =