Migration TimeSeries 12.10
Posted in 2013
Topics: Server Administration, Migration, Import/Export & Data Conversion, Versions, Editions & End-of-Life
Hi everybody,
I migrated a database with TimeSeries data (created with IDS version
11.70) to the new Informix version 12.10.
After the migration Informix 12.1, all seems OK when I run a "SELECT"
sql command with dbaccess for my tables with TimeSeries data.
But, in the file online.log, I have the following ERROR messages, is it
normal ?
12:51:34 Loading Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld>
12:51:34 The C Language Module
</opt/infx1210/extend/TimeSeries.6.00.FC1/TimeSeries.bld> loaded
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:37 Unloading Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld>
12:51:37 The C Language Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld> unloaded
12:51:37 Loading Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld>
12:51:38 The C Language Module
</opt/infx1210/extend/TimeSeries.6.00.FC1/TimeSeries.bld> loaded
Regards
--
Franck Thomas
ConsultiX
franck.thomas@consult-ix.fr
http://www.consult-ix.fr
Téléphone : 33 (0) 1 39 12 18 00
Mobile : 33 (0) 6 78 81 09 33
Fax : 33 (0) 1 39 12 18 18
Hi Franck,
When you executed the SELECT commend, it appears to have been on the
TimeSeries Virtual Table, it is failing because the server could not load
the shared library ($INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld)
for TimeSeries.
The server has resolved library file name to:
/opt/infx1210/extend/TimeSeries.6.00.FC1/TimeSeries.bld
The error message in the log: "reason: Cannot access library file" is
typically happens when the
library does not exist or the server is unable to access it.
Does this file exist? What is the ownership and permissions on it and the
parent directory: /infx1210/extend/TimeSeries.6.00.FC1?
For a normal install, the file and directory should be owned by Informix and
permission on the directory should be readable and searchable (r and x flags
on linux/unix) and the library must be readable by the owner. The library
should not have write permissions.
Hope this helps.
Mark Ashworth
IBM/Informix Extensibility Architect
mailto:ashworth@ca.ibm.com
-----Original Message-----
From: ids-bounces@iiug.org [mailto:ids-bounces@iiug.org] On Behalf Of Franck
THOMAS
Sent: April 11, 2013 7:13 AM
To: ids@iiug.org
Subject: Migration TimeSeries 12.10 [30030]
Hi everybody,
I migrated a database with TimeSeries data (created with IDS version
11.70) to the new Informix version 12.10.
After the migration Informix 12.1, all seems OK when I run a "SELECT"
sql command with dbaccess for my tables with TimeSeries data.
But, in the file online.log, I have the following ERROR messages, is it
normal ?
12:51:34 Loading Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld>
12:51:34 The C Language Module
</opt/infx1210/extend/TimeSeries.6.00.FC1/TimeSeries.bld> loaded
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:34 Loading Module <ts_vtam_close>
12:51:34 (2): The C Language Module <ts_vtam_close> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_close>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:34 Loading Module <ts_vtam_scancost>
12:51:34 (2): The C Language Module <ts_vtam_scancost> can't load
reason: Cannot access library file
12:51:34 (-1): ERROR: Loading Module <ts_vtam_scancost>
12:51:37 Unloading Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld>
12:51:37 The C Language Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld> unloaded
12:51:37 Loading Module
<$INFORMIXDIR/extend/TimeSeries.6.00.FC1/TimeSeries.bld>
12:51:38 The C Language Module
</opt/infx1210/extend/TimeSeries.6.00.FC1/TimeSeries.bld> loaded
Regards
--
Franck Thomas
ConsultiX
franck.thomas@consult-ix.fr
http://www.consult-ix.fr
Téléphone : 33 (0) 1 39 12 18 00
Mobile : 33 (0) 6 78 81 09 33
Fax : 33 (0) 1 39 12 18 18
****************************************************************************
***
Forum Note: Use "Reply" to post a response in the discussion forum.
Hi Frank, Could you double check where these messages are in online.log? If these messages happened during conversion between Conv/rev: calling conversion to 12.10 ... and Conv/rev: blade conversion to 12.10 completed Conv/rev: Finished conversion for component BLADE, you may ignore these messages and your timeseries is still good to use. These messages are just momentary messages and conversion was completed successfully. We are finding a solution to avoid these messages in online.log. If this is not the case and it happened after conversion, please provide more info as Mark indicated. Thanks --weiming