Re: adjacent key locking
Posted in 1997
On 10 Jun 1997, Nicholas Allon wrote: > We are having a similar problems :- > online 7.12 > isolation level is dirty read > lock mode is row level > set wait is 5 Immaterial to the problem at hand (probably), but what platform? > A large(ish) process is inserting into the table in question, as soon as As in how many rows updated? > someone tries to > update this table via a composite primary index they often get timed out > (sql -243 isam 154), how can this happen if we're using the above settings. > My immediate work around is to increase the wait to 10 ( obviously far too > long). Hrm. I'd like to know if that worked. > I will start analysing the application in more detail to reduce the unit of > work, but is strikes me that there is still an adjacent key locking problem > in this scenario. The real issue here, IMnsHO, is that you're dirty read. That /should/ be able to read through an adjacent-row-locking error, no? > Any views ? You tell me, its your database. [duck] -Richard